UltraSPARC MBR problem, Bad Magic Number in Disk Label, will not boot.

Hello, I am looking to see if someone perhaps can help out here. Did a pretty stupid thing by accident and now trying to resolve it.

I wanted to create a ghost image of SUN UltraSPARC Solaris 8 Hard Drive. Well, while attaching it through IDE/SATA USB cable to my Windows laptop to run ghost,
I enabled it through disk management by accident and MBR was written into.

Now, I can't even get the damn thing to boot anymore on the SUN Powerblade 150. This is what I began to see:
Bad Magic Number in Disk Label
Can't open disk label package
Boot device: net File and args:
Timeout waiting for ARP/RARP packet

I have tried the following without any success. Any help is greatly appreciated!! Thank you.

Things I have tried:

1) Tried running fsck
a. Inserted Solaris 8 OS Disk into CD-ROM, Pressed STOP-A, at OK prompt typed boot cdrom -s
b. At single user prompt typed "fsck /dev/rdsk/c0t0d0s0"
c. Rebooted, did not work.

2) Tried to correct disk label
a. Inserted Solaris 8 OS Disk into CD-ROM, Pressed STOP-A, at OK prompt typed boot cdrom -s
b. At single user prompt typed "format", selected the drive c0t0d0s0and labeled it (one error at boot was companing about label being wrong).
3. Rebooted, still no good.

3) Tried to reinstall boot sector.
a. At OK prompt typed boot cdrom -s
b. At single user prompt typed "/usr/sbin/installboot /usr/platform/sun4u/lib/fs/ufs/bootblk /dev/rdsk/c1t0d0s0" to try and reinstall the boot sector.
c. Rebooted, still no good.

4) Tried to zero out/clear the boot code withinMBR (first 446 bytes) using dd. Did not want to do all 512 to preserve partition table.

a. At OK prompt typed boot cdrom -s
b. dd if=/dev/zero of=/dev/rdsk/c0t0d0s0 bs=446 count=1
c. Rebooted, still won't boot

Any help is greatly appreciated!! Thank you!!
vitalyzvAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
bad magic number means there is no formated partitions. The drive may have died.

You needed to run the fsck -b and use one of the alternate super blocks
based on the newfs -n /dev/dsk/c1t0d0s0

0
arnoldCommented:
Additional info.

http://www.unix.com/solaris/17766-big-uh-oh-bad-magic-number-disk-label.html

Do you have a layout backup from this disk that you can "restore"
The problem I see is that what you've attempted may have made things worse.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gheistCommented:
https://secure.wikimedia.org/wikipedia/en/wiki/TestDisk
openbsd also includes ffs searcher/ disklabel rebuilder.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.