Blue Screen on a SBS 2008

When I restart a SBS 2008 server I don't see a blue screen but when it comes back up I get the following message.

The server also seems to take longer the usual to restart...about 20 minutes. The usual time is about 8 to 10 min

 
Problem signature:
  Problem Event Name:	BlueScreen
  OS Version:	6.0.6002.2.2.0.305.9
  Locale ID:	4105

Additional information about the problem:
  BCCode:	1000009f
  BCP1:	0000000000000004
  BCP2:	0000000000000258
  BCP3:	FFFFFA8006CF7BB0
  BCP4:	0000000000000000
  OS Version:	6_0_6002
  Service Pack:	2_0
  Product:	305_2

Files that help describe the problem:
  C:\Windows\Minidump\Mini050711-01.dmp
  C:\Users\KMAdmin\AppData\Local\Temp\2\WER-1012306-0.sysdata.xml
  C:\Users\KMAdmin\AppData\Local\Temp\2\WERC754.tmp.version.txt

Read our privacy statement:
  http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409

Open in new window

LVL 1
GerhardpetAsked:
Who is Participating?
 
lamaslanyCommented:
From the Drivers & Downloads for PowerEdge R210 page download and install the Dell PERC S100 Integrated driver.
0
 
lamaslanyCommented:
Can you upload the minidump?
0
 
GerhardpetAuthor Commented:
Here are the minidump and the files that the problem report describes

 Minidump.zip
 2.zip
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
lamaslanyCommented:
The minidump points to a problem with the Storport storage driver (storport.sys).    How long have you had the problem?


What hardware are you running on?
0
 
GerhardpetAuthor Commented:
The problem thursday last week. The server is a Dell PowerEdge R210

How do I find out which storage driver that is. I have two USB drives on it for backups.

I notice one Event ID on Thursday but I'm not sure if it is related

Event Log:  System
Event Source:  Server Administrator
Event ID:  2056  
Severity: Error  
Details: Virtual disk failed: Virtual Disk 9 Controller 0

The server is setup with 2 physical disks configured as RAID 1
0
 
GerhardpetAuthor Commented:
Any other ideas for me? The server is now very slow and every time I reboot I get the screen promting me to start in normal mode or safe mode. I don't see any blue screen
0
 
lamaslanyCommented:
Do you know what controller is installed?  
0
 
GerhardpetAuthor Commented:
Dell PERC S100 Integrated
0
 
GerhardpetAuthor Commented:
Updating the driver solved the problem

The server is back to normal now for a few days already
0
 
lamaslanyCommented:
Good to hear.  Thanks for the feedback.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.