• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1002
  • Last Modified:

xBox 360 will not auto sign into xBox live

When I switch on my xBox it automatically signs me into my xBox profile, but does not automatically sign me into xBox live.

When I try to sign into xBox live it says "can't connect" and suggests I 'test' my connection using the xBox 'Test Connection' page. When I 'test' the connection it signs me into xBox live first time and stays signed in until I switch the xBox off again.

How can I fix it so that when I am automatically signed into my xBox profile I am also automatically signed into xBox live? (WITHOUT having to use the xBox 'Test Connection' page to make it work).

As per Microsoft's help pages, the xBox has been assigned a static IP, tcp ports 3074, 53 and 80, and udp ports 88, 3074 and 53 are forwarded to the xBox.

Thanks in advance ;)
0
Suncore
Asked:
Suncore
  • 4
  • 3
1 Solution
 
willbaclimonCommented:

Which router or firewall do you have?


Some connections tips

http://www.internetforce.org
0
 
SuncoreAuthor Commented:
Its a Cisco 877W-M running IOS 12.4(15)T10.

xBox has a static (10.10.10.15), port forwarding is in place as per suggestion from the xBox support pages...:

ip nat inside source static udp 10.10.10.15 88 interface Dialer0 88
ip nat inside source static udp 10.10.10.15 3074 interface Dialer0 3074
ip nat inside source static tcp 10.10.10.15 3074 interface Dialer0 3074
ip nat inside source static udp 10.10.10.15 53 interface Dialer0 53
ip nat inside source static tcp 10.10.10.15 53 interface Dialer0 53
ip nat inside source static tcp 10.10.10.15 80 interface Dialer0 80

Thanks for that link, although I couldn't find anything related to this xBox issue on those forums.
0
 
willbaclimonCommented:
oops, here the link

http://internetforce.org/iforce/index.php?/topic/30-cisco-config-for-xbox-live-ports/#entry31

How have a Cisco 1811 and putting the static nat's and access-list will do it. Also make sure you have spanning tree turn off on that port or "portfast"
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
SuncoreAuthor Commented:
Looks good, I am going to give that a try, thank you.  Will post back.
0
 
SuncoreAuthor Commented:
willbaclimon,

You have solved the issue - thank you, thank you thank you.

Disabled spanning tree and it worked straight away.  I would love to know out of interest how you knew that STP had to be disabled?????

0
 
willbaclimonCommented:
I having been in Network Security field for 14 years :)
0
 
SuncoreAuthor Commented:
As per expert suggestion, disabled STP - now working.  Thank you EE & willbaclimon.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now