Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 824
  • Last Modified:

HP printer prints intermittently.

Client has PC running XP SP3.

Printer is HP Laserjet M1522n. Bizarre problem. It will print one or two documents then stop.

No error on printer - 'Printer Ready'. Print Spooler service still running. Documents queued.

Nothing will start them printing.

 I uninstalled all the HP software and downloaded the PCL5 (what is this??) driver.

Again it printed a test page, then several documents. Then it was left for 10 minutes and after that refused to print anything again.

The HP downloads site has me completely confused - there are numerous driver packages for this printer and I have no idea which one to use or whether it is a driver problem at all.

Help gratefully received.
0
chrisfixit
Asked:
chrisfixit
5 Solutions
 
houssam_balloutCommented:
did you try to connect it to a different computer?
0
 
chrisfixitAuthor Commented:
No not yet, there's only one in her office. I will take my laptop over.
0
 
ocanada_techguyCommented:
First, ask yourself, when did this problem start happening, and what changed?  If within 30 days or so, you could try using the System Restore to put the system back the way it was, and see if the problem goes away.  You're probably past that now since you've tried changing printer drivers and other changes to what files remain on the hard disk.

This multifunction printer, are you connected via it's USB 2.0 or Ethernet?  Is there more than one computer that prints to it?  Running XP as you've indicated, this first computer is presumably older, how old, old enough that its USB ports are USB 1.1 not 2.0?  (some had both, use a 2.0)   The HP printer spec says usb 2.0.

Old machines without could have a $11 PCI card that gives USB 2.0 ports, if you go that route maybe even check cost of a USB 3.0 card which could prove useful for the speed it could offer not to the printer no but any new external hard drives that support usb 3.0

My first suspicion would be the motherboard drivers under XP for supporting the on-board USB on the computer in question.  Is the motherboard BIOS up-to-date and are you using the latest stable drivers from the motherboard manufacturer?  If the drivers are buggy, they might have a problem with speed handshaking (see below) OR it might be that when the computer puts the devices into low-power state, that is a contributor to the problem.  

Before you go opening a can of worms trying motherboard firmware updates, try fiddling with the power management.  Perhaps in Device Manager try changing the Allow computer to turn off this device to save power on the Power Management tab of the appropriate USB controller or Root Hub.  (I know it can be near impossible to distingish which root hub corresponds to which port so you may have to do them all)

If changing the power management does fix it, you could live it with it like that, or you could then consider updating the mobo bios and corresponding drivers as an update may very well have resolved a power-management issue with the device drivers.

The USB bus is shared by all devices attached via USB, mouse, cam, drives, etc.  Few machines offer more than one usb channel bus.  Try isolating the possible cause by disconnecting all other USB devices and see what happens.  A badly behaving device may be changing the USB from hi-speed to one of the several other speeds usb supports, and this may throw the device for a loop.  A separate expansion PCI usb card might not have the same issues.

It is not outside the realm of possibility that the issue exists with the printer driver software.  XP has come out with many hotfixes and service packs in its lifetime.  You say you tried a PCL5 driver instead.  Have you tried completely removing the HP printer software and downloading and using their uninstall utility to make sure all of it was removed everywhere on the drive and registry?  Then the question becomes is there a "provided by Microsoft" somewhat generic printer driver that might work, or is the only driver for this multi-function device the one HP provides, and have you tried the latest one.

Also, similar to updating the bios so the usb hardware and drivers can be updated, it is actually possible with many HP printers, especially the multi-functions ones, to flash "update" their firmware.  Perhaps the brains of the printer needs an update.  

Goes back to the initial question, did this machine work fine before and then something changed? (or is this the first time you're trying this printer with this computer)
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ocanada_techguyCommented:
Is the USB cable exceedingly long?  I have seen some flimsy cables, although thats usually only a problem with usb hard drives, the amount of data on a printer usually precludes that being the problem, but try a better cable or no more than 6 ft.

HP tends to put on an "HP updater" utility on people's machines, so possibly an HP update happened lately, which now has this problem, and if it were possible to rollback the hp driver/software to the version before the update possibly the problem would go away.
On the other hand if critical hotfixes from Microsoft for XP have somehow caused a new issue, then those ciritical updates are important so then the onus is on getting the HP to work with it, not the other way round.
0
 
chrisfixitAuthor Commented:
OK, the problem presented itself in April after the winter closure of the office apparently (it's in a yacht chartering business and is seasonal).

The printer is attached by USB and there is no network, only one PC, but now you mention it when I swapped USB ports I did get the messge "..would work faster in a USB 2.0 port..)

How can I tell which (if any) USB ports are 2.0 and which 1.1 ??
0
 
hdhondtCommented:
If it acts like this from multiple PCs (or if you only have 1 PC), I would reset the printer to factory defaults, as follows:

1. Turn off the printer.
2. Press and hold both the down arrow button and the Cancel button, and then turn on the printer.
3. Wait until the message "Permanent storage init". appears, and then release the buttons.

When the NVRAM initialization process finishes, the printer's control panel shows the Ready message.

You will have to reset all settings in the printer, including:

- All network settings
- All menu settings, including the fax header and company name
- Fax numbers and names that are associated with one-touch keys and speed-dial codes.

Re PCL5.
Better printers have a built-in command language; examples are PCL5, PostScript and Esc/P. These languages are used to tell the printer what to put where on the page. Cheaper printers on the other hand are "host-based", also called GDI or PCL3 (some HP printers). These rely entirely on the Windows graphics engine to turn the page into dots on the paper. Printers that have a language usually perform faster, and will keep working with new versions of the operating system. Host-based printers have no such guarantee.
0
 
ocanada_techguyCommented:
The Universal Print Driver is a simple "just be able to print" type driver that works with all kinds of situations like Remote Desktop, Terminal Services, etc etc.  They offer PCL6, PostScript, or PCL5 printer language.  the "printer language" is the set of commands and codes that tell the printer to put a line from cordinate x1y1 to x2y2, or more complex things like describing a font in minute detail.

The much larger downloads, those drivers are a software bundle that includes all the multi-function capabilities such as scanning.  Why so many choices?  Well, it depends if you prefer PostScript or PCL6 (just go with with PCL6 unless you're some sort of tyeface printshop or Apple users and prefer PostScript)  And as you can see it depends if you're connecting from computer to printer via USB, or Ethernet, and if there's other computers on the network that would also like to be able to use the device as a scanner then there are the "Scan/Print" as opposed to just the "Print" driver packages.  That's why so many.  And then of course your TZ reads Eastern Europe, so there;s the whole what language is the printer in, what language do you want the software and drivers in, and most important of all in all that, what language or Windows are you trying to run it on, you should try matching the language of windows most probably.  And here's a shocker, the US English tends to get bugs fixed soonerr than other languages.
0
 
ocanada_techguyCommented:
If it says would work faster THEN it's not 2.0 that's a USB 1 or 1.1 port.

However, it did work properly before?  Ugh, that means trying to figure out what changed.  Of course Microsoft has come out with XP hotfixes, for the most part those security issues should not affect the printer stuff, or USB behaviour, but it might.

Try the power management.
0
 
ocanada_techguyCommented:
Oh, you could try resetting the printer to factory.  You'd then have to set it up again, fax numbers, speed dials might be lost, or the software on the computer might save all those settings, HP's sometimes does.  Along similar lines, if that doesn't work, I'll bet the firware of the HP printer your client is using is not the latest, since HP appears to have updated the firmware 20100902  2 Sep 2010.  So that's another possible thing to try.

HP's English drivers for this printer are dated 6 Mar 2008 so are UNlikely to have changed (what language is your client?)  The software/scanning bundle changed 20 Oct 2010, so maybe that got updated recently.  Similar dates for west european and east european language choices.

Me, I'd be tempted to go to the support website of the computer/motherboard maker and note what is the latest motherboard BIOS that is not beta, the thinking being that the issue is USB related.   What BIOS version is your client's computer?

The site should also have drivers for the motherboard chipset (which would include the usb support)  and any integrated audio, graphics, network device drivers.

You might need to use a aflash or pflash utility to flash the BIOS firmware.  Used to be you had to make a floppy to do this.  Some of the newer ones can run right in windows.  Their tool might be safe and reliable enough that it makes a backup copy of the existing BIOS before it flashes the new BIOS, if NOT, it is always advideable that you be able to put the BIOS back to the previous version, just in case things are worse not better.  If the version you client is using now is also available for download from the manuf website, fine, download that one just in case you need it, otherwise use the BIOS flashing tool to make a backup of the current BIOS before updating, would be the most prudent course of action.
Then you install the updated device drivers.  It's a good idea to have the latest driver for chipset, network, audio and graphics all downloaded and unpacked onto your hard disk ready to go, as often after a BIOS update the plug-n-play detects the hardware change and searches for drivers.  The other way to force this is in device manager remove the device, then scan for hardware change or just reboot and it'll plug-n-play detect and then you choose the latest driver, specifying the filepath where you unpacked your downloads if you like.

The HP software driver bundle tends to be more complex, and their instructions tend to want you to NOT let Windows autodetect or se microsoft's driver, and to NOT have the printer attached at all until a certain point halfway through the installation of the bundle.
0
 
chrisfixitAuthor Commented:
Ok, all USB ports are 1.1 .

I updated all chipset/system drivers to latest versions.

I downloaded the HP PCL6 USB Express Scan/Print Driver Package and tried to install.. when it asks for the printer to be connected it sometimes didn't detect it, other times it did but it would always seem to stop installing some minutes after detecting it (0% CPU) and sometimes fall over with 'cannot run dll as app' error.
0
 
ocanada_techguyCommented:
Hmmm, so the USB is working intermittently it would seem.  What's the cable look like, high quality or no?

Desktop have an available PCI slot?  A PCI usb card isn't expensive, might take time and another trip to get one however.

Since the printer supports working via Ethernet, that might be another way of connecting to consider.  Without a router might need a crossover cable.

Maybe it's the printer end of the USB that's malfunctioning.   Does the printer work consistently if attached to your laptop or other computer?  For that you could try the simpler universal printer driver, or even try the whole software bundle, you could always uninstall it and the use System Restore to make sure your laptop's registry is back the way it was before if you wanted to be absolutely sure no leftovers ramined.

And that last one "cannot run dll as app", inconsistently, geez that's a weird one for sure.  Do a backup of all important files.  The system may be failing.  Chipset may have overheated and now is damaged.  

Some tools let you monitor, but if the damage is already done this won't help after the fact
http://www.mydigitallife.info/2010/03/22/check-and-monitor-computer-cpu-and-gpu-temperature-voltage-or-fan-speed/ 
0
 
chrisfixitAuthor Commented:
Ok, tomorrow morning I'll go with laptop and ethernet cable and make sure the printer itself is Ok and possibly if connecting with ethernet via router works.

failing that I think it's time they invested in a new PC/laptop :-)
0
 
ocanada_techguyCommented:
Aside: I like to run HDDRegenerator (or SpinRite or HDat2) on older systems, as older hard drives tend to accumulate bad sectors, so called "soft errors" and I prefer these programs because they usually sucessfully get the data off the bad spots before remapping whereas more often than not chkdsk with the /r option sets them aside BUT fails to get the data so all files affected by bad sectoring are thus corrupted and then you're expected to replace those files, which can be a challenge if without the right media, service packs, or customer hasn't backed up (which is too often the case)

I add this because of the "sometimes"  happening "'cannot run dll as app' error" what is that makes me wonder, could be failing hardware, could be intermittent corruption on drive.

Maybe look in the Event Log for errors, which could offer clues to what's not working right.  Are there allot of errors? errors from source disk?
0
 
chrisfixitAuthor Commented:
Thanks, I'lll check tomorrow.
0
 
chrisfixitAuthor Commented:
Ok, it appeared to be the USB connection on the printer - sent it back as it was under guarantee.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now