How do i get my WSS 3.0 site up again as the site now says "Service unavailable" when trying to open with webbrowser after i had detached and and attached the content DB i SQL Express 2005?

Posted on 2011-05-07
Last Modified: 2012-05-11
I get the message "Service unavailable" on my WSS 3.0 intranet site after detaching, moving and attaching the WSS content database

I was running out of harddrive space on C: so i had to move physical location of the database files.

My idea was to shut down the webpages on IIS, then detach, move the .mdf and .ldf files for the WSS content database. attach the database in WSS and finally start the IIS WSS websites and everyting would work fine but no.

Now i get the message "Service unavailable" when i try to open my WSS site. Same goes for the admin page, can't open it either as i get the same message en the m webbrowser.

I am using MS SQL server exress 2005 and WSS 3.0 and Windows Server 2003 R2.
I've tried restarting the server but no affect. Still the same error message.

I've tried adding the db_owner permission to the reattached wss content database to the domain account that the wss site runs on but no affect. Should i use "stsadm.exe -o addcontentdb" or some other options to stsadm.exe to add the content database to my WSS? Could it be that by detaching the content database from the SQL Server it was also removed from WSS?

If i need to re-install everything are there content files stored on the harddrive on the server that need to be backed up and after reinstall of WSS overwrite existing files? I have backups of the database that worked.

Anyone who has had this problem?
What do i need to do to get it working again?
Question by:JaniMP
    LVL 14

    Accepted Solution

    service unavailable is possible application pool stopped.

    make sure you web application is running.

    Author Comment

    Any suggestions on how to make sure the web application is running an if not running how to start an application pool?

    Author Comment

    I went to IIS and checked under upplication pools and sure the application pool was not running. I started it and everything works fine.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Introduction SQL Server Integration Services can read XML files, that’s known by every BI developer.  (If you didn’t, don’t worry, I’m aiming this article at newcomers as well.) But how far can you go?  When does the XML Source component become …
    These days socially coordinated efforts have turned into a critical requirement for enterprises.
    This video shows, step by step, how to configure Oracle Heterogeneous Services via the Generic Gateway Agent in order to make a connection from an Oracle session and access a remote SQL Server database table.
    This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    13 Experts available now in Live!

    Get 1:1 Help Now