Failed Data Validation

Posted on 2011-05-07
Last Modified: 2012-05-11
I transferred a huge data ( over 3 million records ) from our old oracle server to our SQL Server which is configured as Merge Replication.
During data transfer from Oracle to SQL Server, the primary filegroup got full, so I increased its size then resumed data transfer, after that the data transferr completed successfully to our SQL Server, during that it was replicating to SQL Server subscribers.
The merge agent for the subscribers has finished replicating the new data successfully.
But when I tried to validate the data on the clients, row count was different for some tables!!
Is it possible that because of the filegroup error, the merge replication had some serious problem in keeping these tables in sync?
What is the best practice if I want to copy a huge data intto a merge replication topology?
How to be sure 100% that the data in all subscribers are accurate ? should I validate the subscriptions each time they syncronize?
Question by:TaibaDXB
    LVL 15

    Accepted Solution


    Author Comment

    Thanks for your reply.
    The first article says Replication triggers are not fired during Bulk Operation, but the data was replicating to subscribers during my Data Import, so it means that triggers were fired during this import!!!
    But is seems that it wasn't fired for some records!!
    I am using SSIS to import my data, & it seems that it is not using Bulk Insert.
    Any other ideas?

    Author Comment

    After going into deep checking into the merge agent history details, it turns out that it was replicating all the records for only one table during our Data Import, but not for the remaining tables because I have set in the SSIS OLE DB Destination ( Data Access Mode: Table or View - fast load ).
    So the first table has replicated all data correctly to all subscribers & that table passed data validation.
    But for the other tables, it didn't replicate because it seems that it was considered as Bulk Operation, so the row count at subscribers for these tables were 0 after data import was finished.
    After a few hours when someone tried to use some data from these tables, it seems that it triggered the replication to copy some records but not all of them!!
    How this can be explained?

    Featured Post

    Threat Intelligence Starter Resources

    Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

    Join & Write a Comment

    Hi all, It is important and often overlooked to understand “Database properties”. Often we see questions about "log files" or "where is the database" and one of the easiest ways to get general information about your database is to use “Database p…
    In this article I will describe the Detach & Attach method as one possible migration process and I will add the extra tasks needed for an upgrade when and where is applied so it will cover all.
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now