[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

All Users Desktop shortcut changing path by itself

Posted on 2011-05-07
6
Medium Priority
?
636 Views
Last Modified: 2013-11-21
I have a dynamic shortcut path in an icon on the All Users Desktop of a terminal server maching.
The target path looks something like this:  c:\Documents and Settings\%username%\Timas\myApp.exe
the Start In path looks similar: C:\Documents and Settings\%Username%\TIMAS
For some reason the target path will on occasion mysteriously change from the dynamic setting to the profile name of one of the terminal server users like this.
c:\Documents and Settings\mBrooks\Timas\myApp.exe
The Start In path doesn't change. So of course when anyone other than mBrooks logs in and clicks on the shortcut they receive an error. Any Ideas as to what can be causing this? And I know that it isn't mBrooks changing it because that's me.
0
Comment
Question by:BradleyCleveland
6 Comments
 
LVL 11

Expert Comment

by:marek1712
ID: 35715847
Hmm, strange. Did you try to set the shortcut as read only for EVERYONE (I mean not user, but every group, including SYSTEM)?
0
 
LVL 47

Expert Comment

by:apache09
ID: 35716935
Sounds as if these Terminal Server users may also have romaing profiles setup.
Check their Ad Accounts
0
 
LVL 17

Expert Comment

by:Spike99
ID: 35734828
You could also try setting the shortcut icon to :  %userprofile%\timas\myapp.exe.

That would also cover users who have a temp local profile or a secondary profile folder to which the domain has been appended (C:\Document and Settings\TEMP or C:\Documents and Settings\UserName.DOMAIN for example).
0
Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

 
LVL 6

Accepted Solution

by:
ipajones earned 2000 total points
ID: 35784519
Sounds lilke your username is the owner of the shortcut (.LNK) file.  Change the owner to system.
--IJ
0
 
LVL 1

Author Closing Comment

by:BradleyCleveland
ID: 35915446
What I did is created another user and then created the shortcut under that new user's profile. No one ever logs in under this new profile and so far the shortcut hasn't changed.  The system wouldn't allow me to use the %profilename% variable in the shortcut
0
 
LVL 17

Expert Comment

by:Spike99
ID: 35915781
The variables you could use are either %userprofile% or %username%.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
Know what services you can and cannot, should and should not combine on your server.
Screencast - Getting to Know the Pipeline
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question