Sony Vaio Windows 7 Wireless Boot Time

Posted on 2011-05-07
Last Modified: 2013-12-27
I have Sony Vaio running Windows 7 Ultimate Edition.  I am running Linksys E3000 wireless router.  Everytime I boot my laptop, my wireless connection takes approximately 80 seconds to connect.  Sometimes I have seen longer.  There are no startup programs that runs in the background.  

I do have VMware Workstation installed and yest, I do have virtual network connections for VM but they don't load on startup.  All VM services are disabled.  

It is annoying that I have to almost wait for 90 seconds for wireless to connect to wireless router and the icons to stabalize in system tray.

Any help is appreciated to speed up this process.

Question by:kaushalk
    LVL 12

    Expert Comment

    by:John Griffith
    Try Ethernet connection - see if Internet connects immediately.

    Do you have a Wireless Manager installed?  Or are you using Windows Zero Configuration?
    I've seen some new laptops recently that include OEM wifi manager - unnecessary w/ Windows 7.

    If wifi Mgr installed - uninstall it.

    What wifi device do you have?
    Check Device Manager.
    LVL 4

    Expert Comment

    Is it happening with all the Laptops connected to the same wifi or only in the Vaio ?

    Author Comment

    No wireless manager has been installed. I have Atheros AR9285 wireless network adapter.

    Author Comment

    I only have 1 laptop connecting. I used to have Vaio before too but never had this latency problem in the past. I don't have that old Vaio anymore.
    LVL 4

    Expert Comment

    Can you disable the Wifi security, put the wifi channel selection in Auto and see.
    LVL 30

    Accepted Solution

    Boot the computer in safe mode with networking and then check the time it takes to connect....the problem might be caused by startup program or security software.

    Try safe mode with networking. ..first..if everything works fine then try clean boot in normal mode.

    Clean boot

    Start- msconfig- click on startup tab- click disable all- click services tab- put a check on hide all microsoft services-click disable all -click ok. Restart the computer.

    Check the time taken to connect.


    Author Comment


    Going through msconfig worked for me.  Nothing critical was under startup tab so I left it alone.  Under services tab, I followed your directions and now it takes 4 seconds to connect.

    Great improvement.  Excellent suggestion.  Thanks

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
    DECT technology has become a popular standard for wireless voice communication. DECT devices are not likely to be affected by other electronic devices and signals because they operate in a separate frequency-band.
    This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
    This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now