Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 595
  • Last Modified:

perl modules gives me error message

Hello All,

It took me some time to install and compile Library system Koha with its perl modules, next I managed to login to http://10.1.3.30:8080. But at the webpage (Web Installer > Step 1) stage, where it asks me to choose language which is “en: and press next. It goes nowhere and under “/var/log/koha/koha-error_log” it shows bellow error:

((((

[Sun May 08 12:10:13 2011] [client 10.1.3.99] [Sun May  8 12:10:13 2011] install.pl: Use of uninitialized value in split at /usr/share/koha/lib/C4/Languages.pm line 145., referer: http://10.1.3.30:8080/cgi-bin/koha/installer/install.pl
[Sun May 08 12:10:13 2011] [client 10.1.3.99] [Sun May  8 12:10:13 2011] install.pl: Use of uninitialized value in pattern match (m//) at /usr/share/koha/lib/C4/Languages.pm line 430., referer: http://10.1.3.30:8080/cgi-bin/koha/installer/install.pl
[Sun May 08 12:10:13 2011] [client 10.1.3.99] [Sun May  8 12:10:13 2011] install.pl: Use of uninitialized value in string eq at /usr/share/koha/lib/C4/Languages.pm line 307., referer: http://10.1.3.30:8080/cgi-bin/koha/installer/install.pl
[Sun May 08 12:10:13 2011] [client 10.1.3.99] [Sun May  8 12:10:13 2011] install.pl: Use of uninitialized value in string eq at /usr/share/koha/lib/C4/Languages.pm line 325., referer: http://10.1.3.30:8080/cgi-bin/koha/installer/install.pl
[Sun May 08 12:10:14 2011] [client 10.1.3.99] /usr/bin/perl: symbol lookup error: /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Graphics/Magick/Magick.so: undefined symbol: InitializeMagick, referer: http://10.1.3.30:8080/cgi-bin/koha/installer/install.pl

)))

That some thing to do with Perl configuration any idea what is that?
0
uknet80
Asked:
uknet80
  • 4
  • 4
5 Solutions
 
wilcoxonCommented:
The "Use of uninitialized" lines are warnings and may or may not indicate a problem.

The "symbol lookup error" lines appears to be a real error but it is more of an operating system error saying that the compiled shared library (Magick.so) does not contain something it should.  As a first step, I would try to run a small script using Graphics::Magick to test if it works outside of the Koha system (I'm guessing it won't).  If it doesn't, then you need to reinstall Graphics::Magick.
0
 
wesly_chenCommented:
http://stats.workbuffer.org/irclog/koha/2010-05-22#i_446736
-------
check PerlDependencies.pm and comment out Graphics::Magick to see you can compile through.
0
 
uknet80Author Commented:
I have uninstalled GraphicMagick-perl, and that solved the problem.  although one of the requirement for koha library was Graphics::Magick.  do you think that affect the anything, what is the module used for?

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
wesly_chenCommented:
what kind of Linux and the Koha version you try to install?
It's better fulfill all the requirement.
0
 
uknet80Author Commented:
cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.4 (Tikanga)

Koha 3.2.5.

Under CPAN Graphics::Magic is not available and if I install rpm version which is (GraphicsMagick-perl, GraphicsMagick) it gives error as you so before.
0
 
wesly_chenCommented:
It has a bug in Koha C4/Installer/PerlModules.pm which parses the version number incorrectly.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5599

So do
koha_perl_deps.pl -u
and
make sure you install the version of above of GraphicsMagick-perl.

Then as my previous post mentioned:
http://www.experts-exchange.com/Programming/Languages/Scripting/Perl/Q_27025045.html?cid=1572#a35716581
------------
check PerlDependencies.pm and comment out Graphics::Magick to see you can compile through.
0
 
uknet80Author Commented:
koha_perl_deps.pl -u
command not found
0
 
wesly_chenCommented:
As root
find / -name koha_perl_deps.pl
You doesn't not set path to that script.
0
 
uknet80Author Commented:
the solution was to remove Graphics:Magic, I couldn't find module for that.

thanks
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now