Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Configuring VLANs in 3750

Posted on 2011-05-08
4
Medium Priority
?
394 Views
Last Modified: 2012-06-22
Hi,

I have configured a VLAN using following commands:

SWITCH01(config)# vlan 50
SWITCH01(config-if)#Exit
SWITCH01(config)# interface vlan 50
SWITCH01(config-if)# ip address 172.16.50.254 255.255.255.0
SWITCH01(config-if)# no shutdown
SWITCH01(config-if)# exit
SWITCH01(config)#interface giga 1/0/1
SWITCH01(config-if-range)#switchport
SWITCH01(config-if-range)#switchport host
SWITCH01(config-if-range)#switchport access vlan 50
SWITCH01(config-if-range)#spanning-tree portfast disable
SWITCH01(config-if-range)#no shutdown

This is a Cisco 3750 switch, first of all I don't understand what these commands mean, I just searched on Google and followed insturctions, all I can see is that VLAN 50 is configured and Switch port 1 is part of VLAN 50 now.

On same switch from port # 13 to 23 I have other servers connected, they are in default vlan1 and have IP addresses of different subnets e.g. 128.128.x.x/16, 192.168.1.0/24 etc

No IP adress is configured in switch for vlan1.

My problem is, I'm unable to ping devices from vlan50 to vlan1 and vice versa, I'm sure I'm missing something, please guide me in right direction, regards.
0
Comment
Question by:tayyabq8
  • 2
4 Comments
 
LVL 7

Accepted Solution

by:
Ironmannen earned 1000 total points
ID: 35716435
Hello
To route between two vlans you have to have ip routing enabled:
conf t
ip routing

Then you also must have an ip interface for vlan wich is on ONE subnet only. You can't have two subnets on the same vlan. Take a new vlan for the other subnet:

SWITCH01(config)# vlan 1
SWITCH01(config-if)#Exit
SWITCH01(config)# interface vlan 1
SWITCH01(config-if)# ip address 128.128.X.X 255.255.0.0
SWITCH01(config-if)# no shutdown
SWITCH01(config-if)# exit


SWITCH01(config)# vlan 10
SWITCH01(config-if)#Exit
SWITCH01(config)# interface vlan 10
SWITCH01(config-if)# ip address 192.168.1.X 255.255.0.0
SWITCH01(config-if)# no shutdown
SWITCH01(config-if)# exit

0
 

Author Comment

by:tayyabq8
ID: 35716474
Hi,

Thanks for your reply. So you are saying, now I have to create a different VLAN for each subnet which was available in default vlan1, but they are able to communicate to each other without IP interface, they can't only communicate to newly created vlan50?

what i understand after reading, once i create vlans for different subnets, then I have to change default gateway of my servers as well who are connected to these ports? and similarly users as well, there is no way i can't use this default vlan1 the way it is now? sorry for my ignorance.

You haven't used switchport commands, aren't they required?

Regards,
0
 
LVL 7

Expert Comment

by:Ironmannen
ID: 35716502
Hello
You don't have to applogize, you are here to get your questions answered...

You have understanded it correctly, one subnet per vlan and point the computers default gateway to the ip of switch (it is called SVI - Switch Virtual Interface).

A client port must be configured as a access-port and assigned to a vlan but if it is only clients or servers connected eg. no switches, I would disable  "spanning-tree portfast disable" with "no spanning-tree portfast disable", on new ports you just don't add the line
0
 
LVL 26

Assisted Solution

by:Soulja
Soulja earned 1000 total points
ID: 35720349
You can do this also, if you want to keep the two old subnets on VLAN 1.

SWITCH01(config)# vlan 1
SWITCH01(config-if)#Exit
SWITCH01(config)# interface vlan 1
SWITCH01(config-if)# ip address 128.128.X.X 255.255.0.0
SWITCH01(config-if)# ip address 192.168.1.X 255.255.0.0 secondary
SWITCH01(config-if)# no shutdown
SWITCH01(config-if)# exit

On another note, why are you using a /16?

0

Featured Post

Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
In this article, we’ll look at how to deploy ProxySQL.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question