MS SQL Server Database Diagram does not show table relations

I have a database and want to see its table relationships. I did the Create New Database Diagram operation and selected the tables I want, but it only shows the table columns but there is not arrows or lines that show inter-relationship among the tables?!

What am I missing?
TongZAsked:
Who is Participating?
 
TongZConnect With a Mentor Author Commented:
I would like to close this question without assigning points.
0
 
Éric MoreauSenior .Net ConsultantCommented:
do you have foreign keys defined?
0
 
TongZAuthor Commented:
All keys including foreign key are defined.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
Éric MoreauSenior .Net ConsultantCommented:
have you tried to draw any new relations on your diagrams? the relations should appear automatically as there are no option to make them visible or not.

is this diagram upgraded from an earlier version of SQL Server?
0
 
TongZAuthor Commented:
there was no existing diagram, I am creating the first one and it is not upgrade from earlier version of SQL Server.

What I did notice is that in some of the examples, I see the schema name is in parenthesis after the table name, which I don't see on mine. Also, do I need to "Add" all tables in the DB?
0
 
Alpesh PatelAssistant ConsultantCommented:
Hi, If you have Primary-Foregnkey relation then no need to add it. Just Add table and it will automatically create links.
0
 
TongZAuthor Commented:
This is a project related question which was a long time ago, it was not resolved but it was needed anymore for that project. Hence, would like to close the question.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.