rs_helpdb show replication errors

Posted on 2011-05-08
Last Modified: 2012-05-11
I tried to resume the replication, but it was failed, when I checked rs_helpdb I got the status like this.

should the status ON for db involve in replication ?
what is the cause of this status goes OFF ?

1> rs_helpdb
 dsname                         dbname                         dbid        controlling_prs                 status
 ------------------------------ ------------------------------ ----------- ------------------------------  ----------------------------------------------------------------------------------------------------
 K_Za_001              SimpliCity                             122 REP_SVR                        Log Transfer is OFF,
 (return status = 0)
Question by:motioneye
    LVL 24

    Accepted Solution

    Is that a primary or a replicate? We only expect log transfer to be on for a database that is a source of replicated transactions.

    It's always helpful to run

         admin who_is_down

    in a RepServer to help narrow down exactly what RS threads are down. Have a look at the RepServer errorlog, too. (Both the primary and replicate, if you have more than one RepServer.)

    Author Comment

    How do we check whether its primary or replicate ? actually I have no idea how this replication get setup.
    LVL 24

    Expert Comment

    by:Joe Woodhouse
    Well, where are you replicating from, and where are you replicating to?

    Author Comment

    Its from sybase to sybase, but I have no idea how to identify function of each db server. Furthermore when I run admin show_connections, it does not provide me with actual server name except sybase data server only.
    LVL 24

    Assisted Solution

    by:Joe Woodhouse
    Sybase Replication only knows about database and dataserver names. You can resolve those to hosts in the Sybase interfaces file.

    I'm not sure what your question is now... we can talk about why a log transfer might be off (most common reason - because it isn't a source of replicated transactions, only a destination; next most common reason, it's been suspended and hasn't been resumed), but if you still need a hand with the basics, the troubleshooting isn't going to make a lot of sense.

    Probably best to take a look through the Rep Server manuals... start with the Design Guide and the Troubleshooting Guide.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Suggested Solutions

    Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
    In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
    Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now