• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 356
  • Last Modified:

Mozilla auto configure ignored proxy hosts

Hi there Experts,

I am having some issues with a mozilla client configuration. Basically in this office there are a dozen or so internal resources that we need to access (all on the 10.0.0.0 subnet) all of which have their own names so you know "intranet" or "nvision" that kind of thing.

On top of that, because I am a developer I also have a considerable amount of host entries for local sites that I might be developing so say "my.projectname.localhost" or something like that (but not all are formatted like that)

Now what's irritating me at the minute is that for every new site I have to go into mozilla's network config and add an ignored host entry which get's a little tedious after a while.

Is there a way of getting mozilla to bypass the proxy for any addresses that can be found in the hosts file without having to manually add them all?

I know that I can use wildcards in the matching of what I deem to be a "local" address but even that requires some setup time and frankly is more than I can be bothered with!

(by the way using Ubuntu 11.04 and firefox 4.0.1)

Thanks!

Tom
0
temmygray
Asked:
temmygray
  • 8
  • 7
1 Solution
 
upanwarCommented:
In Mozila you can not use wild cards but you can bypass entire network.

As you have mentied that you have network subnet 10.0.0.0 and if the subnet mask is 255.255.255.0
then you can enter 10.0.0.0/24 in no proxy for, This entry will bypass proxy for this subnet.

If you want to bypass for all new subdomains then you can enter .your_domain.com It will bypass all subdomain and domain from proxy.

Let us know If you face any issue.
0
 
temmygrayAuthor Commented:
Thanks for your comment upanwar,

As much as I can match an entire subnet and that's OK, I rarely ever reference any of these sites by their IP addresses so that's not going to work.

If I can't force mozilla to read from hosts file before putting through proxy is there any way I can add items into it's "allowed hosts" from an external program?

Many thanks
0
 
upanwarCommented:
Bypassed IP should work with the URLs as well. ANy how the URL would be resolved by DNS or host file to IP.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
temmygrayAuthor Commented:
upanwar: In my allowed exceptions bit, at the moment I have:

localhost, companyintranet, 127.0.0.1, 10.1.0.0/24, 10.1.3.0/24

Open in new window


When I attempt to access my wiki say, which when I ping responds as 10.1.3.235 then it attempts to go through the wiki.

Do you know why this might be happening?

Many thanks

Tom
0
 
upanwarCommented:
Could you please show us output of below given command from the box.

# ipconfig /all

Please provide the output from the machine from both network.

10.1.0.0 and 10.1.3.0
0
 
temmygrayAuthor Commented:
Sorry I don't quite understand what you mean by "Please provide the output from the machine from both network." I assume you mean can I paste the contents of an IP config.

It will have to be an ifconfig as am running ubuntu:

tom@web-40:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 6c:62:6d:00:00:00  
          inet addr:10.1.0.115  Bcast:10.3.255.255  Mask:255.252.0.0
          inet6 addr: fe80::6e62:6dff:fec8:4d02/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:250021 errors:0 dropped:0 overruns:0 frame:0
          TX packets:98997 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:109981116 (109.9 MB)  TX bytes:14875070 (14.8 MB)
          Interrupt:42 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1086 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1086 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1239450 (1.2 MB)  TX bytes:1239450 (1.2 MB)

wlan0     Link encap:Ethernet  HWaddr 70:f1:a1:00:00:00 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Open in new window

0
 
upanwarCommented:
As per the showing subnet mask please make the below given entry to bypass the proxy.

10.1.0.0/14

then try, It should work.
0
 
temmygrayAuthor Commented:
Nope sorry, still going through the proxy :(
0
 
upanwarCommented:
What is the name of your localdomain? how are you accessing the local site via full name or short name?

Paste the content of

cat /etc/resolv.conf
0
 
temmygrayAuthor Commented:
Sorry, can't post the local domain but access the site by attempting to visit "http://web-wiki/" which my dns servers:

nameserver 10.1.3.151
nameserver 10.1.3.152

Open in new window


Respond with:

tom@web-40:~$ dig web-wiki

; <<>> DiG 9.7.3 <<>> web-wiki
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 24663
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;web-wiki.			IN	A

;; Query time: 0 msec
;; SERVER: 10.1.3.151#53(10.1.3.151)
;; WHEN: Mon May  9 15:51:22 2011
;; MSG SIZE  rcvd: 26

Open in new window

0
 
upanwarCommented:
Could you please enter below given line in your resolv.conf at the top.

search yourlocaldomain.com


and then bypass the below given entries in mozila.

.yourlocaldomain.com, *.yourlocaldomain.com

and then try.
0
 
temmygrayAuthor Commented:
upanwar: I am not sure if I understand exactly what you need me to do.

Do you want me to add "search yourlocaldomain.com" literally to my resolv.conf?

Or should I replace yourlocaldomain.com with the local domain of my network?

Secondly,

Is there any way I can add to the mozila ignored sites list outside of mozilla because that would clear up all my issues.

Thanks
0
 
upanwarCommented:
replace yourlocaldomain.com with the local domain of my network. I will search and let you know if there is any option available for mozila to ignore site list outside of mozila.

0
 
temmygrayAuthor Commented:
I think this needs to be closed with no resolution as there does not seem to be a way to add entries into mozilla's ignored hosts externally.

THanks for your help upanwar.
0
 
temmygrayAuthor Commented:
It is not possible to put items into the ignored hosts from outside mozilla.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now