• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 626
  • Last Modified:

Exchange Un-read messages count not synchronising properly

I have Exchange Server 2010 on Windows Server 2008. I have an email account which I access in 3 ways:-

1) Using Microsoft Office Outlook 2007 on a Windows 7 64bit PC (this is the main way I access my account)

2) Using Microsoft Outlook for Mac 2011

3) Using Exchange Outlook Web Access


Unfortunately the number of un-read messages in my inbox does not syncronise properly with all 3 mediums. This problem occurs regularily.

I have just answered all but 1 of my emails using my Office 2007 PC. There is 1 un-read message in my inbox. Outlook is telling me it is syncronised with the Exchange server, and I have also manually syncronised it. I have also closed and re-opened Outlook.

However, when I access Outlook Web Access, or sync up my Office for Mac 2011 device, the un-read messages count is 6.

I have closed and re-opened both the PC & Mac client, and re-synced using the option under the "Tools" menu.

When looking at the list of messages in my Inbox on the Mac or by using OWA, I can only actually see 1 un-read message, even though the total figure reports 6.

Any ideas? It is so annoying, and a little scary as I'm unable to keep track of which figure is accurate. THe problem occurs all the time and the only way I'm able to solve it is by selecting all the old messages in my inbox and choosing "mark as unread"
0
ph9ltdrob
Asked:
ph9ltdrob
  • 7
  • 5
1 Solution
 
Berkson WeinTech FreelancerCommented:
Is it always OWA that reports a number that's higher than what the desktop clients are correctly showing?
0
 
ph9ltdrobAuthor Commented:
Please re-read question.
0
 
Berkson WeinTech FreelancerCommented:
(A reply like that is not a particularly good way of having us help you - please remember that we're all volunteers here) - I see that the mac too shows 6.  Does the PC ever show more unread in the count than really exisits.  For example if you were to read a message in OWA.
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
ph9ltdrobAuthor Commented:
Thanks for the reply

No, generally the PC won't show more un-read messages than OWA and the Mac report.
0
 
ph9ltdrobAuthor Commented:
Contrary to the above, the PC is now showing 7 un-read messages, and OWA and the Mac are showing 6.

I have also just tried upgrading the PC to Office 2010 and this makes no difference.
0
 
Berkson WeinTech FreelancerCommented:
It sounds like the clients aren't updating frequently enough.  How long after reading a message say in Outlook on the PC are you waiting before going to OWA?

Are you using cached mode?  If so, could you temporarily try turning that off and see if the issue is resolved.  I'd also consider not using the Mac at all until you can get the PC and OWA to play nicely.  Then we can add the mac back.
0
 
ph9ltdrobAuthor Commented:
Even if I sync up the Mac and PC manually the problem still persists
0
 
Berkson WeinTech FreelancerCommented:
So if you read a message in OWA, then click send/receive in Outlook on the PC it's ALWAYS wrong?

Please answer my previous questions
Are you using cached mode?
How long after reading a message in one place are you checking the other?
Can you try this with the Mac offline for a bit to insure that the mac isn't reporting something incorrectly?
0
 
ph9ltdrobAuthor Commented:
So if you read a message in OWA, then click send/receive in Outlook on the PC it's ALWAYS wrong?
- No, not always.

Are you using cached mode?
- Yup

How long after reading a message in one place are you checking the other?
- It varies. But I will always make sure that the email client I'm using is synced with Exchange, before then syncing the next email client with Exchange and checking.

Can you try this with the Mac offline for a bit to insure that the mac isn't reporting something incorrectly?
- For a bit yes, but I do need to use it regularly for work.
0
 
Berkson WeinTech FreelancerCommented:
OK, give it a shot with the mac off for a bit and see if the count is off even once.  

Also, please try with cached mode turned off (Again just temporarily).

0
 
ph9ltdrobAuthor Commented:
Couldn't really find a solution for this other than to turn cached mode off on the PC
0
 
ph9ltdrobAuthor Commented:
No actual "solution" was found... other than a conclusion to give up using cached mode.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now