[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1099
  • Last Modified:

how to delete .deb file (urgent,please help me)

Hi
its really urgent hence i am opening multiple question for people attention ..

this is an reference question of this :
http://www.experts-exchange.com/OS/Linux/Q_27027410.html?cid=239#a35724641


is there any way to delete .deb from apt-get ??


i need to solve the bellow error

Do you want to continue [Y/n]? y
Preconfiguring packages ...
dpkg: regarding .../libc-bin_2.11.2-10_i386.deb containing libc-bin:
 package uses Breaks; not supported in this dpkg
dpkg: error processing /var/cache/apt/archives/libc-bin_2.11.2-10_i386.deb (--unpack):
 unsupported dependency problem - not installing libc-bin
dpkg: regarding .../libc6_2.11.2-10_i386.deb containing libc6:
 package uses Breaks; not supported in this dpkg
dpkg: error processing /var/cache/apt/archives/libc6_2.11.2-10_i386.deb (--unpack):
 unsupported dependency problem - not installing libc6
Errors were encountered while processing:
 /var/cache/apt/archives/libc-bin_2.11.2-10_i386.deb
 /var/cache/apt/archives/libc6_2.11.2-10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


i tryed

apt-get -f upgrade

it started to work then its stoped due to uppper error
so i am thinking,
is there any way to delete those .deb file so that apt-get does not try to install from them

please please help me

i need it urgent ..

0
fosiul01
Asked:
fosiul01
3 Solutions
 
fosiul01Author Commented:
no luck  with those solution
0
 
dfkeCommented:
Use bleachbit (as root) to cleanup archive .deb files and temporary files.  

http://bleachbit.sourceforge.net/

or install using sudo apt-get install bleachbit



0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
underskyCommented:
run sudo aptitude, and search this package with "/"

when you press update or install, they show you what dependences are break.

 btw libc-bin is most valuable library, and break dependence of this package ruin many system packages.

if you realy understand what are you doing, you can use

dpkg -i --force-all *package*

but it ruine all, that depend of libc package.

best way use update, from repository, for all package.

tell me what excatly version you need? or look it self here:
http://lauchpad.net/ubuntu/+ppas

you need to apply all dependence to safety install this package.
0
 
underskyCommented:
dpkg, and aptitude can't solve packages problem, that aptitude does.
 but with dpkg you can force install any package, but they can ruin all packages where libc need.
0
 
wesly_chenCommented:
@fosiul01
Any update? Is the issue resolved?
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now