Got Locked-Out from New ThinkPad hard-drive :(

Hi Experts!

Well... I got a brand new Think Pad T420s, got a new $300 OCZ Vertex 3 120GB SSD drive, and been using it for a few weeks..

Few days ago, I took my the hard-drive from my Think Pad ... and put it back in, but then my usual hard-drive password wouldn't let me back in! It just keeps asking for the HD password, and even though I try my usual password(s), I can't get in.

I don't need the data, I just want to be able to use my $300 SSD drive again... but it won't allow me to access it. I tried connecting it to Windows via enclosure, and trying to wipe it with Paragon, but it just keeps showing error messages "Drive not ready", and won't let me access it.

How can I get my drive back and remove the Thinkpad password?

Thanks in advance!

LVL 1
Kaptain1Asked:
Who is Participating?
 
Kaptain1Author Commented:
I've looked everywhere... tried calling OCZ and IBM, but it appears there's no way to reset it. It seems that OCZ SSD drives have issues with password encryption by Lenovo bios - so do not do it, it will corrupt the hd password and you will be locked out forever.
0
 
npinfotechCommented:
0
 
Kaptain1Author Commented:
Thanks, it seems that this method is for locked WD hard-drives.

The fact that I have an SSD drive, does it change anything?
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
npinfotechCommented:
I don't see why; your SSD is most likely connected via sata.  it should still work.
0
 
jamietonerCommented:
Have you tried contacting OCZ? A hdd password is stored on the drive not the computer.
0
 
Kaptain1Author Commented:
Haven't tried, but i voided the warranty of ssd b/c i took it out from the casing in order to fit into my Think Pad 420S (it has 7mm height of the hd bay, as opposed to 9mm regular)... :-/ Not sure if they may have any tools for me to use, but they probably won't exchange it :(
0
 
nobusCommented:
probably you need the Thinkpad password to reset, has  nothing to do with the SSD imo
here some info :  http://www.ja.axxs.net/unlock/
you can also contact ibm for it
0
 
Kaptain1Author Commented:
None of the offered solutions worked. No way to unencrypt the Lenovo hdd password.
0
 
BMPTSCommented:
IBM is full of it we crack passwords (including "corrupted" ones) all the time in the T series laptops.

Here is a bunch of good info:
Site with a TON O GOOD STUFF - http://www.allservice.ro/forum/viewforum.php?f=12
Attached is a how to make one of the cables to talk to the chip
(the cable you need might be different depending on laptop and chip version check the site but if not here ya go)
 
Cable - I2C-Cable.doc
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.