Exchange 2010 problem

Hi

Hope someone can help with the problem

I have Exchange 2010 installed at home and it was working all ok. I am not routing mail through DNS because it is residential line and my provider doesnt allow me to use port 25 but they let me use port 587 with SMTP authentication which I set up and it was all working good.

Later I installed Antispam agents to prevent spam and it was also working good. But right after installing them I was no longer able to send e mail.

I think the reason is that when you setup antispam agents you have to use
Set-TransportConfig -InternalSMTPServers 10.0.1.10 cmdlet and this is I think where the problem is because I am relaying mail through my internet provider not going directly through port 25 but 587. Would I have to uninstall agents or it would be enough to
Set-TransportConfig -InternalSMTPServers smtp.provider.com where provider is the name of my actual provider.

The message i am getting from my provider is "The following organization rejected your message smtp102.provider.yahoo.com

Hope someone has idea what did i do wrong but i think with setting transport config to my internal server didnt work well with my ISP. As I sad i am using it at home and they let me use it with port 587 but with this setting cant send mail.

cer113Asked:
Who is Participating?
 
cer113Author Commented:
This issue has been resolved with my ISP. They assumed I set up exchange server to send large amount of spam. After talking to their representative issue has been resolved and mail is flowing ok
0
 
MinoDCCommented:
try in this way:

you go under the Server Configuration -> Hub Transport ->Anti Spam  and here, you can add the local IP's
0
 
cer113Author Commented:
It was problem with ISP they blocked me assuming spam is the reason for me to set up exchange server at home
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.