• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2203
  • Last Modified:

"Allow this device to wake the computer" problem in Windows 7

Hi - I'll be most impressed by and grateful to the person who solves this conundrum. Key aspects of my setup (so far as I can tell):

Dell Studio XPS 16 laptop
Windows 7 Professional SP1 64 bit
Broadcom NetLink (TM) Gigabit Ethernet

Problem:

I was having a lot of problems whereby I would close my laptop expecting it to go into sleep(standby?) mode, or alternatively I would manually (thru Windows Start button) select for the machine to go into hibernation. In both cases it wouldn't. Typically what would happen is the screen would switch off but the machine wouldn't go into the desired mode, the fan would keep going etc. eventually I would have to simply turn it off the hard way by holding the power button down for a few seconds. When it came back on I would get the usual 'Windows was not shut down properly, you want to start in safe mode?' (or whatever the actual phrase is).

When Windows loaded back in I would get a 'Windows has recovered from a serious error' message, it would check online for a solution but of course never find anything. I would examine the log which simply pointed me to a minidump file which didn't appear to tell me very much.

Anyhow, I eventually found the solution to this problem by reading around the web. The issue was that, under Device Manager, Network Adapters, my built-in ethernet adapter described as 'Broadcom NetLink (TM) Gigabit Ethernet' had a power management tab with the following settings:

'Allow the computer to turn off this device to save power '
'allow this device to wake the computer'
'only allow a magic packet to wake the computer'

All three fields were ticked. The info I found on the web suggested that I should clear the tick from the 'allow this device to wake the computer' field. This I did and it seemed to be the solution to the problem, for a while... I would send the computer into sleep or hibernate and everything would be fine. I'm not sure how long afterwards, it might not have been long, the problem reappeared. I went and checked whether the power management settings for this device were as they were now supposed to be, and to my surprise found that mysteriously the 'allow this device to wake the computer' field now had a tick in it again which I had not put there. I duly unticked it, and things were fine again, until they weren't... The way I would characterise it is that every day or two (I am a power user and I ferry my laptop between home and the office so it gets closed at least a couple of times per day), when I close the lid or select hibernate, the old problem reappears and when I reboot into Windows, hey presto, the mysterious tick in the 'allow this device to wake the computer' field has reappeared!

I believe I have the most up-to-date driver for the Broadcome ethernet adapter: 14.6.1.0

Additionally, I have been through all devices listed under Modems, Network Adapaters, Ports, Sound, video and game controllers, System devices, and Universal Serial Bus controllers to look out for other rogue power management settings, but haven't found any.

I am at a complete loss as to what to try next, so grateful for any suggestions! As you can imagine, having what is in effect a hard crash every day or two is a major impediment to actually getting any work done. Many thanks, Adrian
0
Adrian_Harris
Asked:
Adrian_Harris
  • 6
  • 3
1 Solution
 
Kruno DžoićSystem EngineerCommented:
in win 7
Control Panel\All Control Panel Items\Power Options\System Settings

you have a options to set options

When I close the lid:
0
 
Adrian_HarrisAuthor Commented:
thanks - I'm familiar with those settings and have set them correctly - the machine tries to enter the appropriate mode when I take those actions but it fails to complete the move to sleep/standby or hibernate
0
 
Kruno DžoićSystem EngineerCommented:
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Kruno DžoićSystem EngineerCommented:
0
 
Adrian_HarrisAuthor Commented:
thanks, I checked out Step 3 and found something worth a try: my laptop was listing 2 HID-compliant mouse devices capable of waking up the system, however, possibly more likely, it also listed my "Dell Wireless 5540 HSPA Mini-Card Network Adapter". I used Device Manager to turn off the first two, but could only turn off the third by the elevated command line interface, which for some reason gives me hope.

I will see how this goes for the next couple of days, fingers crossed. If that doesn't work,I shall also check if Step 7 is the solution, which is to set the screensaver to none. Currently I have a screensaver rolling through all my photos in My Pictures. This occasionally stops working, particularly after one of the crashes as described, and I got the sense that it is problematic, so will switch it off if the above steps didn't work.
0
 
Adrian_HarrisAuthor Commented:
follow up - unfortuantely the steps I took on 10th May didn't solve the problem - however, I downloaded TuneUp utilities 2011 which gave me some suspicion that the problem might be my FortiClient VPN software - I uninstalled that yesterday and will test over the weekend to see if that did the trick.
0
 
LeeTutorretiredCommented:
I've requested that this question be deleted for the following reason:

This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
 
Adrian_HarrisAuthor Commented:
ok - here's the solution, which I found myself on another site.

In Control Panel, go to Power Options and select Change plan settings for the power plan you have active.

Next screen, open Change advanced power settings

Select Sleep to expand that tree

i) Allow hybrid sleep - make sure is 'Off' in both cases, I had read this elsewhere and on its own doesn't work, you need to also...

ii) Allow wake timers - in both cases, Disable. Without going into an exposition on what Enable wake timers does, I can safely say that I am pretty sure I had no wake timers configured, but as soon as I disabled this setting, my problem disappeared and the laptop will now happily enter and come out of both Sleep mode and Hibernate.

0
 
Adrian_HarrisAuthor Commented:
on the basis of the solution posted, please just close rather than delete this question - thx
0
 
Adrian_HarrisAuthor Commented:
I am simply filling this comment box in to ensure that the solution remains available for others on the site
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now