• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 467
  • Last Modified:

Right click>open with XPmode app

Can anyone tell me how I can make Win 7 pro see an xpmode app as the default to open apps with...in particular..I have autocad 2009 running in xpmode as the addon we use wont run under win 7. My users cant browse the file system and double click a dwg file and have it open in xpmode autocad
0
smithandandersen
Asked:
smithandandersen
  • 11
  • 10
  • +1
1 Solution
 
Kruno DžoićSystem EngineerCommented:
0
 
smithandandersenAuthor Commented:
M3rc74

Im not referring to compatability mode..thats for apps running under win 7
I talking about XPmode. The app runs fine in xpmode vm but win 7 doesnt see it as an app to open files with...must open the app and then browse files inside the app to open
0
 
LeeTutorretiredCommented:
When you installed your autocad program in XP mode, did you select "install for all users"?  If you can't install for all users, you can simply choose "Open All Users" on the start menu, and copy a shortcut to the application into the start menu's programs folder.
 
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
smithandandersenAuthor Commented:
Lee

Autocad is available from the start menu just as it should be under xpmode apps
When I right click on a dwg file while working in win 7 I need the option to open it with my xpmode autocad
0
 
ded9Commented:
I tried it in my windows 7 and it works...what u have to do is copy the shortcut of autocad to the allusers folder. ...If possible right click on the autocad file and post the screenshot.


Ded9
0
 
ded9Commented:
Allusers folder in windows xp.


Ded9
0
 
smithandandersenAuthor Commented:
I think you guys are missing the point here

In my XPmode the shortcut is already there under all users
In my Win 7 I have a shortcut in program files\WVPC\Win XPmode apps\autocad 2009 that runs the app like a champ

What i am hoping to accomplish is simply have the virtual app auto open when I am browsings files in win 7. Currently in the Win 7 if I browse my data servers...double click on a .dwg it asks me what program to use to open, however I can point it to my xpmode app
0
 
smithandandersenAuthor Commented:
sorry...cant point it to my xpmode app
0
 
ded9Commented:
Got it.. what i want to know is when u right click on the dwg file do u get autocad with xp mode option.


Ded9
0
 
smithandandersenAuthor Commented:
Hi Ded9

No I dont...lol..my users are giving me grief over it
0
 
ded9Commented:
Now one last question ...you said the files are on data servers...can u copy the file on the win7 desktop ..right click the dwg file and check whether u get the option.



Ded9
0
 
smithandandersenAuthor Commented:
Hi Ded9

I just tried it....still not showing in the open with list
0
 
ded9Commented:
The option will register automatically when u launching  xp mode app. The option gets registered in
hkey class root...now i think this computer is connected to a domain...chances are there might be some restriction to the registry.

Just want to know whether this computer is connected to a domain.


Ded9
0
 
smithandandersenAuthor Commented:
yes..the win 7 and xpmode are both joined to a domain
0
 
ded9Commented:
Okay lets check whether there is restrictions on the hkey root...in your windows xp ..copy the internet explorer shortcut in allusers folder...after that shutdown xp mode..

Now in windows 7 xp mode app list launch internet explorer... open yahoo and tried to save the yahoo page on the desktop...close the xp mode app.

Now right click on the saved yahoo html file and check whether u get an option like internet explorer xp mode.

Try it..post results.


Ded9
0
 
smithandandersenAuthor Commented:
Hi Ded9

still no luck

I know its possible as I seen a post somewhere a while back on how to do it but i cant find it anymore :(
0
 
ded9Commented:
were u able to get the internet explorer xp mode in the right click.???????..if no then some security restrictions from domain is creating this problem.




Ded9

0
 
smithandandersenAuthor Commented:
ok....I will reconfigure so both are using domain admin accounts and let you know
0
 
smithandandersenAuthor Commented:
ok....now my xpmode is running under a domain admin account and I am logged in under my domain administrator credentials to the win 7 box and still getting the same result
0
 
ded9Commented:
Can you login locally and then check.


Ded9
0
 
ded9Commented:
Can also try with another account or new account.


Ded9
0
 
smithandandersenAuthor Commented:
Hi Ded9

I tried with several admin accounts and no luck
The IE fav on the desktop doesnt give me an open with option
0
 
ded9Commented:
i hope u have save a website on the desktop... like yahoo.com main page...

Login locally and run subinacl


http://blogs.msdn.com/b/astebner/archive/2006/09/04/739820.aspx

Restart the computer .. login locally and then delete the ie icon from all users xp .. shutdown xp mode... start xp mode again and copy the ie icon to all users.

Now close xp mode and try to launch internet explorer from xp mode app list. .. close ie and then right click on the saved ie website on the desktop ...check whether u get the option.


Ded9
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 11
  • 10
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now