?
Solved

503 Service Unavailable

Posted on 2011-05-10
22
Medium Priority
?
10,156 Views
Last Modified: 2012-05-11
My server went down earlier and i decided to re-install and upgrade from server 2008 to server 2008 r2 (with iis 7.5)

I copied all the files from the website root to the new server and hoped it should work, but only get error 503 Service unavailable when trying to access the site. The application pool keep getting stopped and when i check the event log it shows me:

 System

  - Provider

   [ Name]  Microsoft-Windows-IIS-W3SVC-WP
   [ Guid]  {670080D9-742A-4187-8D16-41143D1290BD}
   [ EventSourceName]  W3SVC-WP
 
  - EventID 2307

   [ Qualifiers]  49152
 
   Version 0
 
   Level 2
 
   Task 0
 
   Opcode 0
 
   Keywords 0x80000000000000
 
  - TimeCreated

   [ SystemTime]  2011-05-10T19:01:12.000000000Z
 
   EventRecordID 668
 
   Correlation
 
  - Execution

   [ ProcessID]  0
   [ ThreadID]  0
 
   Channel Application
 
   Computer XXX
 
   Security
 

- EventData

  ApplicationPool DefaultAppPool
  ConfigException Cannot read configuration file  
  FileName \\?\<EMPTY>
  LineNumber 0
   02000000

Cannot read configuration file?
I have tried giving various permissions to the web.config file and the applicationhost.config file without any luck. It seems as it doesn't even find the file (since it shows: FileName \\?\<EMPTY> )

Heelp.
0
Comment
Question by:Bionor
  • 11
  • 8
  • 3
22 Comments
 
LVL 4

Expert Comment

by:manishkungwani
ID: 35728349
Is it an ASP.NET website, if so, please check the target version of the WEBSITE!

The .NET Framework version in the APP-POOL should be same as the target version of the website.
Also, If needed I can spend a few minutes to resolve your issue.
0
 
LVL 1

Expert Comment

by:mateojaime07
ID: 35728377
Try moving the web.config file off to seperate location and restart the app pool. If that does not work you may have to setup a new site so that IIS is aware of the proper web.config file then move just your core files to the new site you setup ('without existsing web.config'). IIS 7 does not always play nice when files are copied from 1 IIS server to the other. It is best to export the setup to an XML file from the old web server, then import it to the new IIS. when you use the export/import utility, the new IIS server will import the settings as a new web server.
0
 
LVL 1

Expert Comment

by:mateojaime07
ID: 35728433
You may also want to look at the shared configuration option. click on your server name in IIS >> under management you should see a shared configuration icon.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Bionor
ID: 35728548
I tried creating a new site without the web.config file without any luck. There is nothing in the shared configurations option either.

I'm still getting this:
The worker process for application pool 'DefaultAppPool' encountered an error 'Cannot read configuration file
' trying to read configuration data from file '\\?\<EMPTY>', line number '0'.  The data field contains the error code.
0
 

Author Comment

by:Bionor
ID: 35728560
@ manishkungwani:
If you want have a few minutes, then i'll be forever grateful (yes it is a .net site by the way).
0
 

Author Comment

by:Bionor
ID: 35728576
I have also tried changing the identity of the app pool to network service as this was the identity in iis 7, but without luck.
0
 
LVL 1

Accepted Solution

by:
mateojaime07 earned 1000 total points
ID: 35728624
also make sure that if you had any isapi modules, or extra add on modules that you installed after initial IIS setup,  or settings defined on the old site, that they are installed on the new site. The new site must be EXACTLY like the old. If it is missing anything then it will not be able to instantiate the config file.
0
 

Author Comment

by:Bionor
ID: 35730196
I managed to copy the iis configuration from the old server to this one. I had to edit the <configProtectedData> setting in the applicationhost.config file so that the old config would be accepted on the new system. Now the configuration in IIS manager is exactly the same, and the application pool does not shut down anymore, but still, i get 503 Service unavailable. But it's progress i guess.
0
 
LVL 1

Expert Comment

by:mateojaime07
ID: 35730505
when you make updates to IIS and restart the website do you do it from IIS or the services mmc? Once i get done setting up a site i usually go into the services mmc and restart world wide web serivces to ensure that IIS get s a clean start.
0
 

Author Comment

by:Bionor
ID: 35730683
I restarted the entire machine, and now the app pool shut down again when retrying. I now get one warning and one error:

Warning
A listener channel for protocol 'http' in worker process '2888' serving application pool 'My Lucky G' reported a listener channel failure.  The data field contains the error number.

Error:
The Module DLL C:\Windows\System32\inetsrv\redirect.dll failed to load.  The data is the error.
0
 

Author Comment

by:Bionor
ID: 35731224
I checked the error shown above with the err.exe application and got the following result: Error
Could this mean that it is the sql database that's failing?
0
 

Author Comment

by:Bionor
ID: 35731562
Some more progress. The "redirect.dll" file that could not load because the file was missing. I found out that it was for a feature called http redirect which was not installed on the new server. I installed it, and then i got a similar error about a dll for server side includes.

I installed that also, and then i got a new error that cgi.dll could not load, but i am unable to find out what that is for.

Any help? I tried removing "Cgi Module" from the Modules section in IIS Manager, but could not because something about lock.
0
 
LVL 1

Expert Comment

by:mateojaime07
ID: 35731605
are you using the connection string under asp.net section?. this does appear to be an issue with database ffailing, or the connection
0
 
LVL 1

Expert Comment

by:mateojaime07
ID: 35731642
make sure all modules that were installed on old server , match whats on the new server. If you go to the features and roles setup for the server admin. You will need to make sure all features for the new IIS server match. Under administrative tools>> server manager>> the mmc should load. click on features and look at all the modules installed on the new IIS server. compare this to the old IIS
0
 
LVL 1

Expert Comment

by:mateojaime07
ID: 35731653
your IIS server is looking for the server side includes to be installed from features it looks like
0
 

Author Comment

by:Bionor
ID: 35731776
Yes :) I have managed to get rid of the 503 error! But now i get 500: internal server error. But at least it is progress. Now, if i can only remember how to get the system to show the entire error message.
0
 

Author Comment

by:Bionor
ID: 35731844
The new error message is:

HTTP Error 500.21 - Internal Server Error

Handler "PageHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list

Anyone understand this?
0
 
LVL 4

Assisted Solution

by:manishkungwani
manishkungwani earned 1000 total points
ID: 35732518
If the site is in ASP (not ASP.NET) change the mode of pipeline to native (it has NO managed code written in the parenthesis) otherwise change it to Classic mode ...

Also, I can spend some time after about 10 min ..
0
 

Author Comment

by:Bionor
ID: 35737468
I have managed to get my site up and running again! Wohoo.. Only thing now, is to figure out how to make things work R2 Server style (any tips?, cause right now, it is set up to work like on the first edition of 2008 server.

Thank you all for your efforts. Experts-Exchange.com is the best site on the net for getting help on any issues. I really could not have done it without the precious help from you guys!
0
 

Author Closing Comment

by:Bionor
ID: 35737497
I managed to resolve many if the issues myself, but still i could not have done it without help from you guys!
0
 
LVL 1

Expert Comment

by:mateojaime07
ID: 35737568
Thank you i appreciate the compliment
0
 
LVL 4

Expert Comment

by:manishkungwani
ID: 35738683
You are most welcome ... :)
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

First of all, clustering IIS is something you should rarely consider doing. In almost all cases, Microsoft Network Load Balancing (NLB) (http://technet.microsoft.com/en-us/library/cc758834(WS.10).aspx) is a much better solution when you need to p…
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question