xlsm href problem

Hi Experts,

I have a xlsm file that i open with a href from a html file. The xlsm file have some code in the open workbook so is opens a xlm file. It works fine when i double click the xlsm file, but when it is open through a href link the xlsm file opens but it does not open the xml file?

Can someone help with this?
Dim strname As String
Dim strpath As String
Dim oExcel As Excel.Application
Dim oWX As Workbook
Set oExcel = New Excel.Application
Application.Visible = False
Application.WindowState = xlMinimized
Application.ScreenUpdating = False
strname = Replace(ThisWorkbook.Name, ".xlsm", ".xml")
strpath = ThisWorkbook.Path & "/"
Set oWX = Workbooks.OpenXML(strpath & strname)
Application.Visible = True
Application.WindowState = xlMaximized
Application.ScreenUpdating = True
Application.ThisWorkbook.Close

Open in new window

DCRAPACCESSAsked:
Who is Participating?
 
wellousCommented:
Also please do this in yr IE6 ...
Go to Tools > Internet Options > Advanced > Security > and check "Allow active content to run in files on My Computer".

Pls let me know.
Wellous

0
 
wellousCommented:
Hi,

Would you please explain more, what you are after?
opening xlsm which has xml in the same folder from href ? is that what you want?

Brgds
Wellous
0
 
DCRAPACCESSAuthor Commented:
Yes that is what i want. But i found out something strange. If i press the link(href) in a firefox browser, then there is no problem. But nothing happens when i do the same with IE 6 (that is the version my work place are using :-( )

So it seems that it is some security issue in IE6
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
wellousCommented:
It seems that you need to upgrade the ie version, but anyway before doing that please read this article http://radio.javaranch.com/pascarello/2005/10/26/1130348276996.html

hope it helps,
Wellous
0
 
DCRAPACCESSAuthor Commented:
Hi, the Security setting was the answer :-)
0
 
wellousCommented:
Glad to be for help ;)
Thanks for the points & the grade
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.