• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 884
  • Last Modified:

Outlook cannot connect to new Exchange 2010 Server

We are implementing a new Exchange 2010 Server. I am able to send and recieve e-mail, I can login to the owa exchange site and see my mail and sent mail. But when I try to set-up outlook I get a error that it cannot connect to the exchange server. Ideas? Also this is in a test environment running with a Exchange 2003 server. The plan is to replace the Exchange 2003 server. Any help would be greatly appreciated. Thanks.
0
Nick Daniels
Asked:
Nick Daniels
  • 16
  • 13
  • 9
  • +1
1 Solution
 
spiderwilk007Commented:
In account Settings => Change Account => More Settings =>Security Tab make sure "Encrypt data between Microsoft Outlook and Microsoft Exchange is checked. This is required in Exchange 2010.
0
 
spiderwilk007Commented:
... this is on the Outlook client
0
 
kdgoodknechtCommented:
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
Nick DanielsAuthor Commented:
I have that check. Every time I launch outlook I get "The name cannot be resolved. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action." I have tried it from my XP machine with outlook 2007 and also just for giggles, I threw Outlook on the exchange server to see if I could get it connected and I get the same error. Now on the new Outlook 2010 for Mac is was able to set-up the account fine so I must be missing something here.
0
 
spiderwilk007Commented:
From the file menu choose, "work online".
0
 
Nick DanielsAuthor Commented:
This is just setting up the e-mail account so I don't have that option yet.
0
 
spiderwilk007Commented:
Have you configured all of your DNS settings including autodiscover?
0
 
Nick DanielsAuthor Commented:
I have configured our A record our PTR record and our MX record. What do you mean by autodiscover?
0
 
MegaNuk3Commented:
Did you install the CAS role? Restart the exchange RPC client service.
0
 
Nick DanielsAuthor Commented:
CAS is installed and I have restarted the server and the services. Any other ideas?
0
 
spiderwilk007Commented:
Are the clients and server on the same subnet, or are they on different networks? If you have CAS installed and DNS records setup then they should be able to connect directly to exchange, if they are using RPC to connect there is further configuration that needs to take place.

The autodiscover DNS entry that I mentioned helps to connect clients to the server in Exchange 2007 and later. You basically setup an internal and external A record or CNAME record for autodiscover.{yourdomain}.com.

This article helps explain autodiscover and how it's used in exchange.

http://technet.microsoft.com/en-us/library/bb124251.aspx
0
 
spiderwilk007Commented:
By using autodiscover, Outlook 2007 and 2010 clients will connect to exchange automatically without having to configure anything, as long as you are logged into windows with an AD account that has an associated exchange account.
0
 
spiderwilk007Commented:
Another thing you can check is your recieve connector, make sure you have selected the proper authentication method, Intergrated windows authentication and Exchange server authentication should be checked for sure.
0
 
Nick DanielsAuthor Commented:
Still working on this issue. To the above question these are on different subnets VLAN'd off. On the Mac's we have (VLAN 8) through Oulook 2011 they can connect to the server and send and receive e-mails. It is just through our windows PC's that we are not able to set-up outlook. Also we have connected a Andriod phone to the server and sent and recieved e-mail through this. So what am I missing?
0
 
Nick DanielsAuthor Commented:
Also I set-up autodiscover as listed above below are the results from nslookup

>autodiscover

Name: exchange1.totallabel.net
Address: 192.168.10.19
Aliases: autodiscover.totallabel.net
0
 
MegaNuk3Commented:
Try this hotfix on one of your Outlook 2007 clients and see if it fixes the issue:
http://support.microsoft.com/kb/2475891
0
 
Nick DanielsAuthor Commented:
Sorry, that didn't work. Just so you know we have Outlook 2010 for my test machine, Outlook 2007 on the server and Outlook 2011 (Mac) on my Mac. I can set-up the account on my Mac but not on any of the Windows Based clients (boy...doesn't that seem backwards, usually the other way around). Any other ideas.
0
 
spiderwilk007Commented:
Can you try putting one of the PC's on the same VLAN as the MACs and see what happens?
0
 
MegaNuk3Commented:
Here is the outlook 2010 version of that hotfix:
http://support.microsoft.com/kb/2475877
0
 
MegaNuk3Commented:
On the outlook 2007 can you try the fOllowing:
 test outlook autoconfig:
With outlook open/prompting/configuring, hold down CTRL key and right click on the Outlook icon in the bottom right hand side of your screen, then on the popup menu select the "Test Autoconfiguration". Select that, enter valid credentials and select the "autodiscover" option only and test.

Do you get any errors?
0
 
Nick DanielsAuthor Commented:
To answer the above these are all on the same VLAN. VLAN 10 in this case. The Server is also on VLAN 10.

Also I tried testing outlook autoconfig. I held down the CTRL key and right clicked on the option of Test E-mail Autoconfiguration, then entered my login credentials and it would again error out with cannot find connection to server. I included a screenshot below.   Exchange Error1 Exchange error 2
0
 
spiderwilk007Commented:
What client are you using Microsoft says Outlook has to be 2003 or later to connect to Exchange 2010.
0
 
spiderwilk007Commented:
It appears you are using an older client at a bare minimum you have to have copied the public folders from exchange 2003 to 2010 for the client to work properly, but if ht eclient is older that 2003 it is not officially supported on exchange 2010. You can still use older clients to do POP3 or IMAP.
0
 
spiderwilk007Commented:
Exchange 2010 enforces data encryption between Outlook and the Exchange server. On the client you have to tell Outlook to encrypt data between Microsoft Outlook and Microsoft Exchange. In Outlook 2003 and later this can be found when setting up the account in "account settings" or "Email Accounts" under "more settings" on the Security tab there is a check box. With my 2003 clients I have to set this up without starting Outlook using the "Mail" icon in Control Panel.
0
 
Nick DanielsAuthor Commented:
I am using the following clients.

Machine 1 - On Windows 2008 Server (Exchange 2010) I have Outlook 2007 installed. The above error is from that machine.

Machine 2 - Is a Windows XP SP3 Machine with Outlook 2010 installed. It had the same error as above.

Machine 3 - Macbook, Snow Leopard. Office 2011 with Outlook 2011 installed and it works. I'm able to send and receive through this program.

I can also access Outlook Web App and I'm able to send and receive through that. I have not created a SSL yet so maybe that is my problem. So the only thing not working is OUTLOOK 2007 & OUTLOOK 2010.  Hope that helps clear up some of the confusion.
0
 
spiderwilk007Commented:
Try using the Exchange self signed SSL cert to see if that resolves the issue. Also check your internal URL's in Exchange. Have you tried a PC on VLAN 8 yet? I realize these computers are on the same VLAN as the server, but you never know.
0
 
MegaNuk3Commented:
Can you post a screenshot of the "Test Autoconfiguration" output please.
0
 
Nick DanielsAuthor Commented:
It is screenshot 3 above. After the login prompt that is what came up.
0
 
spiderwilk007Commented:
Have you checked the netbios and DNS entries to make sure the exchange server matches on the network?
0
 
MegaNuk3Commented:
I have never seen a "Test Autoconfiguration" look like that. Can you try it again please?
0
 
Nick DanielsAuthor Commented:
DNS & Netbios match. As far as "Test Autoconfiguration" I don't have that option, I have "Test E-mail Autoconfiguration" and when I click on that it asks for login information which I input in (same login info that works on OWA mail) then it kicks back the error in screenshot 3 of not being able to locate server, if click the "Check Name" box, and it again pops up that error of not being able to locate the server, even though in this case Outlook is installed on the server. So something in the CAS is not allowing outlook to communicate with the server. It's a standard install so it seems odd to be having this problem. Hope that clears things up a bit.
0
 
Nick DanielsAuthor Commented:
Set-up a whole new Outlook Profile and here is the message I'm getting
screenshot.4.jpg
0
 
MegaNuk3Commented:
On the Exchange 2010 server do
Start-->Run-->ExBPA and see if that picks up anything in the 'health check' test.
0
 
Nick DanielsAuthor Commented:
I ran ExBPA and just got a error of "Unrecognized Exchange Signature". Everything else passed.
0
 
Nick DanielsAuthor Commented:
Finally got into the Test E-Mail AutoConfiguration, below is the screenshot.
screenshot.5.jpg
0
 
MegaNuk3Commented:
Can you screenshot the ' unrecognised Exchange Signature' error please?

You may have a problem with the exchange server doing encryption can you please test turning it off on your CAS servers: http://support.microsoft.com/kb/2006508

If rpcclientaccessserver encryption is off and outlook is still not connecting, try disabling the Windows firewall on the CAS server and see what happens to outlook then
0
 
Nick DanielsAuthor Commented:
Well, after tinkering with it enough, I finally got it working.  It's always the little things, that mess us up big.  It turned out to be that the windows firewall was on for the exchange server.  Worked after that was turned off.  I can connect with Outlook 2007 and 2010 now.  Thanks for all the great help everyone!  Your suggestion to disable the firewall was right on meganuk3, thanks!
0
 
MegaNuk3Commented:
When you install exchange it should add rules to the firewall to allow clients to connect.

Yours is the 2nd server that I have come across where the rules are missing...
0
 
Nick DanielsAuthor Commented:
Interesting...  thanks for the help!
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

  • 16
  • 13
  • 9
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now