• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3427
  • Last Modified:

EMC - Running EMCGrab on ESX 4 servers

When running the emcgrab on a esx 4 host I am getting no data collected. Please see the output below.
GrabScript version: 1.3.1
Command line options:
Modules to be processed:  Linux_4 esx_4 pp se clariion inq


Module Linux_4 started at : 10/05/11 - 08:00:48
Module Linux_4 not found.  Skipping ...


Module esx_4 started at : 10/05/11 - 08:00:48
Module esx_4 not found.  Skipping ...


Module pp started at : 10/05/11 - 08:00:48
Module pp not found.  Skipping ...


Module se started at : 10/05/11 - 08:00:48
Module se not found.  Skipping ...


Module clariion started at : 10/05/11 - 08:00:48
Module clariion not found.  Skipping ...


Module inq started at : 10/05/11 - 08:00:48
Module inq not found.  Skipping ...


Data Collection Started at : 10/05/11 - 08:00:48

Data Collection Finished at : 10/05/11 - 08:00:48

Does anybody have any ideas as to why???

Thanks!!
0
MCCAsw
Asked:
MCCAsw
  • 13
  • 9
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Has this just started to happen, or have you just installed these tools?
0
 
MCCAswAuthor Commented:
This is the first time we are trying to run the emcgrab on our esx 4 servers for the first time I believe.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Have you download the correct version for vSphere and not for Linux?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
what version of ESX are you running ESX or ESXi?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
did you extract (untar) all the files on the ESX host? (or otherwise)
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
The script should be run as user root, to prevent any data not being
collected through lack of permissions.

The scripts defines a PATH environment based on the default installation paths
of it's software.  If these are different, some modules may not work.
0
 
MCCAswAuthor Commented:
We are running esx 4, yes all files were (untar) to the esx host. I am running it as root.
0
 
MCCAswAuthor Commented:
do you know how I can figure out what the installation paths
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
and you've changed directory to the emcgrab directory and tried running the script from there?

0
 
MCCAswAuthor Commented:
yes , I have. still no data collected, ahhhhhhhhhhhhhhhhhhhhhhhhhhhhhhh
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
do you have a /usr/emc directory?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
EMC_PATH=/etc:.

PATH=${PATH}:/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/ucb:${EMC_PATH}:${SCRIPTS}:${BIN}

0
 
MCCAswAuthor Commented:
no, there isnt an emc dir
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
where did you extract it?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
did you use  tar -xvf emcgrab_ESX_vSphere_<version>.tar

have you been asked to run this by EMC?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
have you got any file in the outputs directory?

0
 
MCCAswAuthor Commented:
Yes tar -xvf, extradite to temp, yes EMC is asking for it
0
 
MCCAswAuthor Commented:
Yes there is a file in the outputs folder but the text says modules not found, skipping
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if i was you if emc is asking for it and you have valid support i would bounce this issue to them.

my understanding is module not found could be normal.

but you should have a valid output file.
0
 
MCCAswAuthor Commented:
I have reached out to them but they are slow to non responsive. I am not impressed by their support by any means. You have been way more helpful than EMC. I personally would not recommend EMC to anyone for anything.
0
 
MCCAswAuthor Commented:
Didn't resolve but very very helpful and responsive, also very knowledgable!
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I'm sorry to here you say that. We would raise the issue for you, but unfortunately you are not our direct client.  So it's a bit difficult for us to get involved, if you already have a case submitted.
0

Featured Post

Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

  • 13
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now