Intel NIC TEAMING and Cisco 3550 Switch Configuration

I am trying to Team my Intel 4 port NIC card so I can get better bandwidth to my server.  When I go to the properties on my NIC only one NIC is Active, the other 3 say standby.  I want all 4 NICs to be active so they can work together.  I am using LACP (802.3AD) My Cisco Configuration is as follows:

interface Port-channel3
 description SQL-TEAMED-NICS
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 spanning-tree portfast

interface FastEthernet0/29
 description NIC1
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 3 mode passive
!
interface FastEthernet0/30
 description NIC2
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 3 mode passive
!
interface FastEthernet0/31
 description NIC3
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 3 mode passive
!
interface FastEthernet0/32
 description NIC4
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 3 mode passive

Any assistance would be greatly appreciated.  Thanks.
LVL 4
denver218Asked:
Who is Participating?
 
Aaron TomoskySD-WAN SimplifiedCommented:
I believe lacp on the switch is only for swith to switch connections. You use software on the server to team the nics. Usually a seperate download application from the manufacturer. I have broadcom nics and I had to download the broadcom teaming utility. I didn't have to touch the switch config at all.
0
 
eeRootCommented:
How are the NIC's configured in the operating system.  Can you post a screen shot that shows the NIC bundle and what protocol they're set to use?

Also, try changing the channel-group mode to active.
0
 
denver218Author Commented:
I do have the teaming software for my intel NICs, but every doc I am reading says I have to configure an etherchannel on the cisco switch.  I can't get it to work either way.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
SouljaCommented:
I would set them to mode on. This way you don't have to worry about any aggregation protocol, but different NIC vendors have different requirements.
0
 
denver218Author Commented:
I did try changing the channel-group to active, and got the same results.  The address of the team is 10.4.0.130.  Once I team the NICs I cannot pint this address anymore.

If I remove  "channel-group 3 mode active" from the ports, I can again ping the address.

0
 
Aaron TomoskySD-WAN SimplifiedCommented:
I don't know cisco gear but with managed and smart netgear switches I've never had to change switch settings when teaming nics on a server. And I've wath the traffic flow correctly.
0
 
denver218Author Commented:
O,k on the switch ports I removed "channel-group 3 mode passive" and added "channel-group 3 mode auto" and it seems to be working.
0
 
denver218Author Commented:
Thank you all for your comments.  I ended up removing "channel-group 3 mode passive" and adding "channel-group 3 mode auto" to the ports and it is now working.  I guess I just had to play the all the settings until I found one that worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.