Why am I not able to join a computer to the domain when looking at the new DNS server?

I'm in the process of installing a new Windows 2003 Standard Ed. DC, transferring all services over from the old one, and removing the old server from the network.

So far I have installed AD and DNS on the new server, promoted it to the Global Catalog, transferred FSMO roles, and demoted the old server from being a Global Catalog. I have not yet demoted the old server by running dcpromo and removing AD because I have been working on Certificate Services first. That is where I'm at with the two servers.

I just took a client computer, configured the IP address to point at the new DNS server and tried to join the computer to the domain (allianceacademy), but I received the following error:


The domain name "allianceacademy" might be a NetBIOS domain name.  If this is the case, verify[ that the domain name is properly registered with WINS.

If you are certain that the name is not a NetBIOS domain name, then the following information can help you troubleshoot your DNS configuration.

The following error occurred when DNS was queried for the service location (SRV) resource record used to locate an Active Directory Domain Controller (AD DC) for domain "allianceacademy":

The error was: "DNS name does not exist."
(error code 0x0000232B RCODE_NAME_ERROR)

The query was for the SRV record for _ldap._tcp.dc._msdcs.allianceacademy

Common causes of this error include the following:

- The DNS SRV records required to locate a AD DC for the domain are not registered in DNS. These records are registered with a DNS server automatically when a AD DC is added to a domain. They are updated by the AD DC at set intervals. This computer is configured to use DNS servers with the following IP addresses:

192.168.91.16

- One or more of the following zones do not include delegation to its child zone:
allianceacademy
. (the root zone)




When I tried to add the same client to the domain name alliance.k12.ec it seemed to worked.

I then took a second client with the IP settins configured to look at the oringinal DNS server and joined it to the domain with allianceacademy.

How do I fix this discrepancy in the name of the domain? All the other clients on the network are joined to the allianceacademy domain - not the alliance.k12.ec domain. Are the two the same domain just named differently? What exactly is going on here?
AAIAdminAsked:
Who is Participating?
 
Chris DentConnect With a Mentor PowerShell DeveloperCommented:

Every domain has two names, a NetBIOS name, and a DNS name. Is yours really a single-label domain? Check the Primary DNS Suffix for your Domain Controller perhaps (ipconfig /all)? If that is "allianceacademy" on its own, no suffix, then you have a bit more work to do:

http://support.microsoft.com/kb/300684

If this is a new directory, consider a rebuild because Single-Label names are incompatible with, well, almost all of MS's newer server products (Exchange included).

HTH

Chris
0
 
8ubterfug3Commented:
Are the SRV records in DNS on the new domain controller? If not you can first try to restart the netlogon service. If that doesn't work you can run dcdiag /fix. If that doesn't work try running netdiag /fix.
0
 
AAIAdminAuthor Commented:
I looked in the forward lookup zone for an SRV record on both the old and new dns servers and I didn't find one on either. Is this the right place to look?

So if I restart the netlogon service on the new DC then that will automatically fix the SRV record issue?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
AAIAdminAuthor Commented:
The Primary DNS Suffix is returning alliance.k12.ec so it looks like we good in that area.
0
 
Chris DentPowerShell DeveloperCommented:

Then you should be able to join the domain using alliance.k12.ec, the other is reliant on NetBIOS naming which is harder to support unless you have all the infrastructure for that in place (such as WINS servers).

Chris
0
 
AAIAdminAuthor Commented:
okay, that is good to know. I guess it just struck me as strange that I'm able to join the "allianceacademy" domain when i'm pointed to the old DNS server, but when I point to the new DNS server I can't - I have to use the "alliance.k12.ec" domain? I thought maybe something got messed up during the DNS and/or AD part of the server migration.
0
 
Chris DentPowerShell DeveloperCommented:
It shouldn't really matter which you point at because DNS can't resolve that name, it's reliant on NetBIOS which is always a lot of fun.

Chris
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.