• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2655
  • Last Modified:

Problems migrating SBS2003 Exchange to Exchange 2010

Hi

Midway through Dematzer's guide and about to migrate some mailboxes to the new system.

If I select a single mailbox, it fails with:

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:02


Joe Bloggs
Failed

Error:
Service 'net.tcp://exch2010.domain.local/Microsoft.Exchange.MailboxReplicationService' encountered an exception. Error: MapiExceptionCallFailed: Unable to make connection to the server. (hr=0x80004005, ec=1283)
Diagnostic context:
    ......
    Lid: 14744   dwParam: 0x6D9      Msg: EEInfo: Status: 1753
    Lid: 9624    dwParam: 0x6D9      Msg: EEInfo: Detection location: 501
    Lid: 13720   dwParam: 0x6D9      Msg: EEInfo: Flags: 0
    Lid: 11672   dwParam: 0x6D9      Msg: EEInfo: NumberOfParameters: 4
    Lid: 8856    dwParam: 0x6D9      Msg: EEInfo: prm[0]: Unicode string: ncacn_ip_tcp
    Lid: 8856    dwParam: 0x6D9      Msg: EEInfo: prm[1]: Unicode string: SAINTS1
    Lid: 12952   dwParam: 0x6D9      Msg: EEInfo: prm[2]: Long val: -545057711
    Lid: 12952   dwParam: 0x6D9      Msg: EEInfo: prm[3]: Long val: 382312662
    Lid: 45169   StoreEc: 0x824    
    Lid: 44273  
    Lid: 37053   Win32Error: 0x6A6
    Lid: 23065   EcDoConnectEx called [length=112]
    Lid: 17913   EcDoConnectEx returned [ec=0x503][length=56][latency=15]
    Lid: 59505   StoreEc: 0x503    
    Lid: 52465   StoreEc: 0x503    
    Lid: 60065  
    Lid: 33777   StoreEc: 0x503    
    Lid: 59805  
    Lid: 52209   StoreEc: 0x503    
    Lid: 19778  
    Lid: 27970   StoreEc: 0x503    
    Lid: 17730  
    Lid: 25922   StoreEc: 0x503    

Exception details: MapiExceptionCallFailed (80004005): MapiExceptionCallFailed: Unable to make connection to the server. (hr=0x80004005, ec=1283)
Diagnostic context:
    ......
    Lid: 14744   dwParam: 0x6D9      Msg: EEInfo: Status: 1753
    Lid: 9624    dwParam: 0x6D9      Msg: EEInfo: Detection location: 501
    Lid: 13720   dwParam: 0x6D9      Msg: EEInfo: Flags: 0
    Lid: 11672   dwParam: 0x6D9      Msg: EEInfo: NumberOfParameters: 4
    Lid: 8856    dwParam: 0x6D9      Msg: EEInfo: prm[0]: Unicode string: ncacn_ip_tcp
    Lid: 8856    dwParam: 0x6D9      Msg: EEInfo: prm[1]: Unicode string: SAINTS1
    Lid: 12952   dwParam: 0x6D9      Msg: EEInfo: prm[2]: Long val: -545057711
    Lid: 12952   dwParam: 0x6D9      Msg: EEInfo: prm[3]: Long val: 382312662
    Lid: 45169   StoreEc: 0x824    
    Lid: 44273  
    Lid: 37053   Win32Error: 0x6A6
    Lid: 23065   EcDoConnectEx called [length=112]
    Lid: 17913   EcDoConnectEx returned [ec=0x503][length=56][latency=15]
    Lid: 59505   StoreEc: 0x503    
    Lid: 52465   StoreEc: 0x503    
    Lid: 60065  
    Lid: 33777   StoreEc: 0x503    
    Lid: 59805  
    Lid: 52209   StoreEc: 0x503    
    Lid: 19778  
    Lid: 27970   StoreEc: 0x503    
    Lid: 17730  
    Lid: 25922   StoreEc: 0x503    

Exchange Management Shell command attempted:
'domain.local/MyBusiness/Users/SBSUsers/Joe Bloggs' | New-MoveRequest -TargetDatabase 'CompanyMBD'

Elapsed Time: 00:00:02

0
hongedit
Asked:
hongedit
  • 3
  • 2
1 Solution
 
Glen KnightCommented:
Most likely cause is because the user you are using doesn't have permissions to the mailbox on the Exchange 2003 Server (SBS2003) or doesn't have the correct permissions on the Exchange 2010 server.  Most likely the 2003 server.

Did you create a new service account as per the instructions in my guide?
0
 
steinmtoCommented:
Um that is what I posted.
0
 
Glen KnightCommented:
you didn't, you posted the link from the results of a google search to another forum without any annotation or explenation.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
hongeditAuthor Commented:
Well it's working now.

I was using the domain admin acount.

The only thing I can think of that I think may have caused it is the fact that the SBS2003 server is bouncing off the license limit constantly.

Would that have caused it? I rebooted the Exch 2010 server, still did it. Went and grabbed a colleague to show him and it worked!

Sods law.
0
 
Glen KnightCommented:
Permissions  in Exchange can take up to 2 hours to take effect.  Restarting would have made the permission changes take effect straight away.
0
 
hongeditAuthor Commented:
Thank you
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now