• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2514
  • Last Modified:

Trying to Deploy Software with Configuration Manager 2007

Hi,

  I just setup a Configuration Manager 2007 Server (Win Server 2008 R2). I was able to use the Discover feature to pick up alot of the workstations and was able to deploy the Client to a good number of them. I approved one of them for testing. I then created a package (Filezilla) and added the program to the package with the filename and the /S for the silent install. I then created an advertisment to deploy the package to the one machine I approved. The advertisment sat with a status of  Not Started for a long time even though the date for the advertisment was in the past and it was to install as soon as possible. Now the status is Waiting. I have rebooted the PC a number of time and it never installs or changes. Anyone have any ideas? Thanks!
0
C2_tech
Asked:
C2_tech
  • 15
  • 11
1 Solution
 
merowingerCommented:
- Is the Package installed on a Disttribution Point? Check Package Status.
- Check the Execmgr.log and CAS.log file on the Client (C:\windows\system32\ccm\logs).
- Additonally install the Roger Zander Client Center to get an GUI View about what's going on, on the Client.
http://smsclictr.sourceforge.net/

Be careful with the Approved Option. Clients which are not approved can also get Software Instalaltions execpt of them with Secure Data like passwords and so on.
So make sure you split them out with SCCM Boundaries. If they are not assinged then they aren't managed
0
 
C2_techAuthor Commented:
I checked the package and it is assigned to the distribution point, i refreshed the point just to be sure. I ran that GUI and I get access is denied. Also attached are the logs.

The advertisment is set to a specifc collection and the one approved desktop is the only member of that collection.


execmgr.log
CAS.log
0
 
merowingerCommented:
Start the Client Center with elevated Admin Privileges.
Have you defined SCCM Boundaries? The client must be within the Boundaries.
http://technet.microsoft.com/en-us/library/bb633084.aspx
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
C2_techAuthor Commented:
Ok I was running it from the web. I went back and downloaded and installed the program and I was able to connect now.

Ok I did not have a boundary. I set one up based on the AD site. The computer is part of that domain/site.

In the GUI it sees the site code. and if I go to advertisments in it and hit the "Show Adv." button I now see the Advertisment I setup.. Should I restart the PC now?
0
 
merowingerCommented:
Is the Client listed as Assigned in the SCCM Console?!
Trigger a Machine Policy in the Clients Control Panel.
http://systemcentercentral.com/BlogDetails/tabid/143/IndexID/23839/Default.aspx
Best option now is to restart, yes.
0
 
C2_techAuthor Commented:
PCName - System - Domain - SiteCode - Yes - Approved - Yes - No - Advanced - No - Yes

Yep it is assigned. I will try triggering the machine policy and possibly a reboot next.
0
 
merowingerCommented:
allright
0
 
C2_techAuthor Commented:
Ok I triggered the machine policy and nothing happened, I rebooted and nothing happened. Still sitting at waiting. I did notice one thing tho. In the package status it is targeting 1 and installed 1.. I go further in and its pointing to the server for that one machine. Retry and Failed are 0. Does this mean my advertisement isnt assigning it correctly?
0
 
merowingerCommented:
This means that the package is installed correctly.

Also are there configured IP Subnets in your AD Site? Which Subnets are defined and which IP has the client? Please define a IP Range instead of the AD Site Boundary in SCCM.

Still on state WaitingContent?
Can you check the clients folder C:\windows\system32\ccm\cache
Is there anything inside?

Please post the locationservices.log, ContentTransferManager.log and clientlocation.log files located at the Clients Logfiles.

Please check also if the Package Sources are physically located on the DP.
\\Servername\smspkgD$\VNN00003
(Could also be smspkgE$ - depends on the DPs volume)
Are the Sources complete? Any file missing?!

Check the SCCM Site Status if there's a problem with any component.
0
 
C2_techAuthor Commented:
CAS.log now has these entries at the end after the reboot on the client:

 
<![LOG[Location update from CTM for content VNN00003.1 and request {3EC3AC3D-F5EF-4DF4-9122-506D32C9DD12}]LOG]!><time="12:22:51.966+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="7072" file="downloadcontentrequest.cpp:969">
<![LOG[Download request only, ignoring location update]LOG]!><time="12:22:51.966+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="7072" file="downloadcontentrequest.cpp:983">
<![LOG[Releasing content request {3EC3AC3D-F5EF-4DF4-9122-506D32C9DD12}]LOG]!><time="12:31:12.224+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="5200" file="contentaccessservice.cpp:1560">
<![LOG[Canceling CTM job {1F4A7905-095E-46C3-9EFD-E55C55779E4C} for content VNN00003.1]LOG]!><time="12:31:12.224+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="5200" file="downloadmanager.cpp:805">
<![LOG[Error: DeleteDirectory:- Failed to delete Directory C:\Windows\SysWOW64\CCM\Cache\VNN00003.1.System with Error 0x00000002.]LOG]!><time="12:31:12.240+240" date="05-10-2011" component="ContentAccess" context="" type="3" thread="5200" file="delpath.cpp:22">
<![LOG[Requesting content VNN00003.2, size(KB) 4156, under context System with priority Low]LOG]!><time="12:31:12.240+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="5200" file="contentaccessservice.cpp:909">
<![LOG[Submitted CTM job {78A0B3B8-B790-4541-AC80-65F5B1CF388B} to download Content VNN00003.2 under context System]LOG]!><time="12:31:12.256+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="5200" file="downloadmanager.cpp:576">
<![LOG[Successfully created download  request {10B37865-F8C0-4465-A034-5F5075BB6A72} for content VNN00003.2]LOG]!><time="12:31:12.256+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="5200" file="downloadcontentrequest.cpp:804">
<![LOG[Location update from CTM for content VNN00003.2 and request {10B37865-F8C0-4465-A034-5F5075BB6A72}]LOG]!><time="12:31:12.661+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="2908" file="downloadcontentrequest.cpp:969">
<![LOG[Download location found 0 - \\VNNVA10CMS01.VIENNA.NOAM.C2TI.COM\SMSPKGD$\VNN00003\]LOG]!><time="12:31:12.661+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="2908" file="downloadcontentrequest.cpp:977">
<![LOG[Download request only, ignoring location update]LOG]!><time="12:31:12.661+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="2908" file="downloadcontentrequest.cpp:983">
<![LOG[Download started for content VNN00003.2]LOG]!><time="12:31:12.708+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="2908" file="downloadmanager.cpp:1004">
<![LOG[Raising event:
[SMS_CodePage(437), SMS_LocaleID(1033)]
instance of SoftDistDownloadStartedEvent
{
	ClientID = "GUID:D473A814-FBD8-4C8B-955C-AAE963CA4D01";
	DateTime = "20110510163112.724000+000";
	MachineName = "VNNDTZ0KM1-PC";
	PackageId = "VNN00003";
	PackageName = "VNN00003";
	PackageVersion = "2";
	ProcessID = 2944;
	SiteCode = "VNN";
	ThreadID = 2908;
};
]LOG]!><time="12:31:12.724+240" date="05-10-2011" component="ContentAccess" context="" type="1" thread="2908" file="event.cpp:525">

Open in new window

0
 
C2_techAuthor Commented:
Ok, I removed the AD Site Boundary and put in a IP Subnet one (we use 192.168.21.x for users with a subnet of 255.255.248.0) .. I went to smspkgD$ and the FileZilla install file is there.

The client is a Win7 64b system so I had to go to C:\Windows\SysWOW64 to find the CCM folder. I went in Cache and there is a folder: VNN00003.2.System and a file skpswi.dat, the VNN folder is empty.

Since I made a change to the Boundary I will try the Machine policy and maybe a reboot again to see if that makes a difference.
0
 
C2_techAuthor Commented:
Ah Site Status has 1 critical item. SMS_MP_CONTROL_MANAGER. No Errors just Warnings and its all the same warning:

MP has rejected a policy request from GUID:CA11A230-40F8-479B-A185-4B6F1B690226 because it was not approved. The operating system reported error 2147942405: Access is denied.
0
 
merowingerCommented:
Allright. Please check this article and make sure the DP is configured correctly.
http://technet.microsoft.com/en-us/library/cc431377.aspx
0
 
merowingerCommented:
In this case we have to look inside the ClientIDManagerStartup.log at the Client
0
 
C2_techAuthor Commented:
Here is that log
ClientIDManagerStartup.log
0
 
C2_techAuthor Commented:
Checking that link you sent now.
0
 
merowingerCommented:
Allright, the Log is ok.
For testing purpose, please use IP Address Range Boundaries for making sure it's not an Boundary issue.
You can even define the Clients current IP Address as Start and End Address.
There are some known issues with IP Subnet Boundaries.
0
 
C2_techAuthor Commented:
I have everything configured per that link with the exception of Windows Authentication in IIS. I added that. I also removed the Subnet boundary and created an IP range one starting and stopping with the clients IP. I am issuing a machine policy now on it and will try a reboot.
0
 
merowingerCommented:
ok if it still does not work. Check again the Advertisement State in Client Center and post all recent Client Logs here.
0
 
C2_techAuthor Commented:
Ok still not installing.. Here are all the logs, let me know if i missed any you need. - BTW thanks for all your help in this so far.. I have been banging my head against the wall on this issue.


ClientIDManagerStartup.log
ClientLocation.log
ClientLocation-20110509-141014.log
CAS.log
execmgr.log
0
 
C2_techAuthor Commented:
System Status - Advertisment Status
  Filezilla - Received 1 - Failures 0 - Programs Started 0 - Program Errors 0 - Program Success 0 - Program Errors (MIF) 0 - Program Success (MIF) 0 - Package FileZilla - Program FileZilla 3.4.0 - Target Collection Software: FileZilla 3.4.0 - Available after 11:5600AM 5/5/11 - Expires Never - Advertisement VNN20001

0
 
merowingerCommented:
Can you access the sources via UNC path?
\\servername\SMSPKGD$\VNN00003

Also try to configure the Advertisement so that the installation takses place from the network.

Try to recreate the package

Is there a folder inside the source which is called "Bin" or some files with one of the following extensions:
*.asax
*.ascx
*.master
*.skin
*.browser
*.sitemap
*.config
*.cs
*.csproj
*.vb
*.vbproj
*.webinfo
*.licx
*.resx
*.resources
*.mdb
*.vjsproj
*.java
*.jsl
*.ldb
*.dsdgm
*.ssdgm
*.lsad
*.ssmap
*.cd
*.dsprototype
*.lsaprototype
*.sdm
*.sdmDocument
*.mdf
*.ldf
*.ad
*.dd
*.ldd
*.sd
*.adprototype
*.lddprototype
*.exclude
*.refresh
*.compiled
*.msgx
*.vsdisco
0
 
C2_techAuthor Commented:
I can go to the path and the only thing in there is FileZilla_3.4.0_win32-setup.exe

I will try your suggestions of the advertisements and package
0
 
C2_techAuthor Commented:
I changed the Advertisement to Install from the DP and not download and it made no difference. I will have to work on recreating the package tomorrow.
0
 
C2_techAuthor Commented:
I restarted the Server, then my PC.. After maybe 20m I got a popup saying it was going to run an advertised program - FileZilla. I hit run and walla! It is installed on the Test PC! So to properly configure the Boundary should I go back to a Subnet Boundary or should I just modify the IP Range one to include all of the DHCP Scope?
0
 
merowingerCommented:
cool, ok.
The best idea is to use IP Ranges as you get no problem when you do Subnetting in your environment. It's a little bit more input needed, but afterwards you will not have any probs with them
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 15
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now