Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

HP Vlans

Posted on 2011-05-10
16
Medium Priority
?
672 Views
Last Modified: 2012-05-11
Hello

I have connected a Laptop to a RJ45 in the network. Then Patched the port to RJ45 in the wall on the Vlan, Then I assign a static IP of
i/p 10.22.30.10
s/n 255.255.255.0
G/w 10.22.30.1

I can ping the network switch on 192.168.1.221 but i can't get to the internet? do i need a special route? Our domain conroller/DNS server IP address is 192.168.1.35. I download a program called solar winds, I can ping 6 address on the ip range of 192.168.1.1/24 but i can't ping 192.168.1.1 or 192.168.1.35

Encloed the Config

Running configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "Switchoffice"
time timezone 1
module 1 type J9147A
ip default-gateway 192.168.1.1
ip routing
vlan 1
name "Lan"
untagged 1-12
ip address dhcp-bootp
tagged 48
no untagged 13-47
exit
vlan 100
name "DMZ"
untagged 37-47
ip address 172.16.8.1 255.255.255.128
tagged 48
exit
vlan 20
name "Voip"
untagged 13-24
ip address 192.168.42.1 255.255.255.0
tagged 48
exit
vlan 30
name "UP Lan"
untagged 25-36
ip address 10.22.30.1 255.255.255.0
exit
Ip route 0.0.0.0 0.0.0.0 192.168.1.1 (our default gateway)
ip route 10.22.30.0 255.255.255.0 192.168.1.1
banner motd "This is a private system maintained by the Corporation"
snmp-server community "public" unrestricted
0
Comment
Question by:andrewh123
  • 8
  • 7
16 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35730302
Your default-route next hop address (192.168.1.1) in unreachable because there is no interface on this switch with a 192.168.1.0/24 address.
0
 
LVL 1

Author Comment

by:andrewh123
ID: 35730363
Hello

How I access is the switch is I type in 192.168.1.221, I add this from windowos server 2003 Mac address of the switch is that correct?
0
 
LVL 6

Accepted Solution

by:
RKinsp earned 2000 total points
ID: 35731155
Hello Andrew, not quite sure I understood your last question. How did you get the configuration of the switch? You should use the same method to edit the configuration (telnet on windows to 10.22.30.1 for example).

Like Don said, you will need to another another VLAN interface on the 192.168.1.0 network.
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
LVL 1

Author Comment

by:andrewh123
ID: 35735724
I connected to the switch using putty on 192.168.1.221 to change the config, or i type in 192.168.1.221 from the web console to view the switch
So I need this
vlan 40
name "New Lan"
untagged 40-48 (need to change the other vlans ports )
ip address 192.168.1.0 255.255.255.0
tagged 48
0
 
LVL 1

Author Comment

by:andrewh123
ID: 35736427
hello
The full conf

On vlan one i add the switch mac address to our windows server 2003 dchp server, what disp out our ip address in the 192.168.1.* range
Running configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "Switchoffice"
module 1 type J9147A
ip routing
vlan 1
name "Default Lan"
untagged 1-12
ip address dhcp-bootp
tagged 48
no untagged 13-47
exit
vlan 100
name "Guest Internet"
untagged 37-47
ip address 172.16.8.1 255.255.255.128
tagged 48
exit
vlan 20
name "Voip"
untagged 13-24
ip address 192.168.42.1 255.255.255.0
exit
vlan 30
name "UP Lan"
untagged 25-36
ip address 10.22.30.1 255.255.255.0
exit
interface 40
monitor
exit
0
 
LVL 6

Assisted Solution

by:RKinsp
RKinsp earned 2000 total points
ID: 35737346
Hello,

I think I get it. Your VLAN 1 is getting an IP from DHCP-bootp, so it is probably getting the 192.168.1.221, meaning that you have an interface on the 192.168.1.0 network.

Use the SHOW commands to see that IP VLAN 1 is getting (example show ip or show vlans, can't remember which works)

You should really consider using a fixed IP for this interface. If your DHCP ever changes you might have problems with routing and/or management.


Anyways, it sounds like your problem might be the VLAN tag. I'm guessing your router is connected to Port 48? If so, try setting VLAN 1 as untagged on that port instead of tagged.

Regards,
RK


0
 
LVL 1

Author Comment

by:andrewh123
ID: 35737801
Hello,

No the router is not connect to port 48, I have a switch in the office connected by fibre to another office that how to two switches talk to each other. I had orginal
Vlan 10
ipaddress 192.168.1.100 255.255.255.0
exit

But when I patched the servers  into the switch on ports 1-11 I got no response from the servers? I have a dchp server dishing out ip to the clients 192.168.1.35 to 192.168.1.253,The serevrs all have static ip up to .35.  When i change the switch to dchp I got a response from the servers so I left it. What happens If i change the default Vlan? I have all the servers on swicth port 1-10
0
 
LVL 6

Assisted Solution

by:RKinsp
RKinsp earned 2000 total points
ID: 35737878
Ok, you cannot change the "default-vlan" to another vlan (example, 10).  There are a couple of possible reasons why you could not ping when you set up vlan 10: 1) if the IP is already in use 2) if the ports that where on the default vlan instead

What you should do is set up the static IP for VLAN 1 that you wanted to set up for vlan 10, making sure it is not in use. then test it with ping.

The switch you have connected on port 48, is it using tagged vlans? Also, where is your router (192.168.1.1) physically connected?

RK
0
 
LVL 1

Author Comment

by:andrewh123
ID: 35738016
Ok,
we have two buildings connected by fibre going across on a network gear switch then connected to firewall then router that building has the internet connection
the office has a netgear not managed on the 192.168.1.1/24 range
So we wanted to split the network so we bought two HP switches using the firbre to connect the switches  on port 48 then start to vlan the network(see above conf)
Its show vlans
vlan id   name
1           lan   port-based  no
20 Voip   port based
30 up lan port based
100 dmz port based
so on vlan 1
ip enabled
lan dchp/boot 192.168.1.221 255.255.255.0
vop Manual 192.168.42.1 255.255.255.0
up lan manual 10.22.30.1 255.255.255.0
dmz manual 172.16.8.1 255.255.255.128

Cheers

I might to start again from scratch

0
 
LVL 6

Assisted Solution

by:RKinsp
RKinsp earned 2000 total points
ID: 35738142
Hello Andrew,

I don't see a problem with what you are testing, it it just a question of physical connections to VLANs that needs to be re-checked.

You said your firewall is connected to the switch. Questions:
1) who has the 192.168.1.1 IP?
2) what physical port is the netgear connected to?

just let me see if I understand the physical aspect you have something like this:

HP procurve -----> netgear (unmanaged) ----->  firewall -------> router ------> internet
0
 
LVL 1

Author Comment

by:andrewh123
ID: 35738170
That looks perfect
I thought the cisco asa5510 firewall is 192.168.1.1
Port 2 is the connection between HP and the netgear  won't any port from 2-11 which? on the HP switch?
0
 
LVL 6

Assisted Solution

by:RKinsp
RKinsp earned 2000 total points
ID: 35738232
Yep, i did mean on the HP switch.

Ok, port 2 on the HP is connected to the netgear which is connected to the firewall.

VLAN 1 has IP 192.168.1.221 (DHCP).

Can you ping 192.168.1.1 from the switch?

Does the Cisco ASA answer pings? (some firewalls are programmed not to answer pings)

If you can ping 192.168.1.1 from the switch, it is likely that you need new static routes on your Cisco ASA for the internal networks.

You need to point the 10..22.30.x, 172.16.8.x, 192.168.48.x to the 192.168.1.221 address (which is why i don't recommend DHCP. if that IP changes, you will need to fix the routes).

-RK

0
 
LVL 1

Author Comment

by:andrewh123
ID: 35738278
Hello,

Never knew that, Yes from the command line of the swicth I can ping 192.168.1.1
192.168.1.1 is alive , time = 4ms

0
 
LVL 6

Assisted Solution

by:RKinsp
RKinsp earned 2000 total points
ID: 35738468
Ok, so the problem is the ASA routes.

Your network knows how to get to the internet, because you have a default route pointing to the firewall. But the firewall does not know how to get back. Once you add these static routes, it will know how to get back. (you can't use a single 0.0.0.0 default route because you need that to point to the router/internet)

Good luck!
RK
0
 
LVL 1

Author Closing Comment

by:andrewh123
ID: 35738490
Thank you for help, You learn something new every day
0
 
LVL 6

Expert Comment

by:RKinsp
ID: 35740762
Thanks for the points. Glad I could help.

-RK
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
With just a little bit of  SQL and VBA, many doors open to cool things like synchronize a list box to display data relevant to other information on a form.  If you have never written code or looked at an SQL statement before, no problem! ...  give i…
The Relationships Diagram is a good way to get an overall view of what a database is keeping track of. It is also where relationships are defined. A relationship specifies how two tables connect to each other. As you build tables in Microsoft Ac…
Suggested Courses
Course of the Month13 days, 9 hours left to enroll

581 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question