• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1719
  • Last Modified:

RHEL 5.6 and 10GB NIC

I was connected to RHEL 5.6 through a 10GB card that was working properly

I reboot and disabled hyperthreading.

Upon reboot the 10GB card was not coming up

From the Java console I performed the following:

network service restart
Bringing up interface eth0:
SIOCSIFFLAGS: Device or resource busy
Failed to bring up eth0

ipconfig eth0 up
SIOCSIFFLAGS: Resource temporarily unavailable

ethtool eth0
Settings for eth0
        Supported ports:  [ FIBRE ]
        Supported link modes:    10000baseT/Full
        Supports auto-negotiation: No
        Advertised link modes:   10000baseT/Full
        Advertised auto-negotiation: No
        Speed: Unknown!
        Duplex: Unknow! (255)
        Port: Fibre
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        Supports Wake-on: d
        Wake-on: d
        Current message level: 0x000000000 (0)
        Link detected: no    

Open in new window

Any ideas on where I go from here ?
Los Angeles1
Los Angeles1
  • 2
  • 2
  • 2
  • +1
1 Solution
Try recycling power.
Assuming you disabled for low latency and that the correct device is eth0. Did you boot using the same kernel?

Please check your modprode.conf file to verify the correct kernel module is loaded.

ethtool -i eth0 (look for module)
modinfo (module from above)
ifdown eth0
ifup eth0
ethtool -t eth0

You can also use mii-tool to test if ethtool is not installed.

1. Reboot and enable hyperthreading to validate the change as the causative agent.
2. Once the system is online as root do lsmod and exec the above to isolate modules, interfaces, devices.

Use insmod to load the module if it's missing. The find or locate commands can help you locate the full path to the module.
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

Los Angeles1Author Commented:
I brought the eth0 down and used ifup to bring it up again, but it still said

SIOCSIFFLAGS: Resource temporarily unavailable

Open in new window

I performed the ethtool -t test, Can I assume from this that the eth0 NIC is working properly, and that there is another problem ?

ethtool -t eth0
The test result is PASS
The text extra info:
register_test (offline)  0
memory_test (offline)    0
loopback_test (offline)  0
mvram_test (online)      0
interrupt_test (online)  0
link_test (online)       0
idle check (online)      0

Open in new window

I have never used the lsmod oommand before, I can not find
a module that would correspond to eth0:

lsmod | grep eth
cdc_ether        39480  0
usbnet           51145  1 cdc_ether

Open in new window

Could you please give me some advice on this ?
If you re-enable hyperthreading does it come back?    
Los Angeles1Author Commented:
Just re-enabled HT, but still get the same problem
Please provide the output of the following command (as root)
dmesg | grep -i eth
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now