select email domains stuck in exchange 2003 outbound queue

i've read through http://www.experts-exchange.com/Software/Server_Software/Email_Servers/A_2427-Problems-sending-mail-to-one-or-more-external-domains.html
and all is well. nothing has changed on my server network and email has been flowing fine with my settings for over a year.

recently in the last 6 days i've been having issues with domains like gmail, yahoo and hotmail. but also a few other domains.
essentially just one email sits in the queue retrying while the other emails for the domain wait queued.

looking at say the gmail smtp log i get this:

25 - - 220+**************************************** 0
25 EHLO - mysmtpserver.mydomain.com 0
25 - - 250-mx.google.com+at+your+service,+[my.ip.address.00] 0
25 MAIL - FROM:<user@mydomain.com>+SIZE=86444 0
25 - - 250+2.1.0+OK+a26si12302980faa.202 0
25 RCPT - TO:<user@gmail.com> 0
25 - - 250+2.1.5+OK+a26si12302980faa.202 0
25 DATA - - 0
25 - - 354++Go+ahead+a26si12302980faa.202 0

if i freeze the gmail queue for an hour or so. then emails will flow through again. how can i track down why i get stuck?

i'm not on any blacklists for any of my smtp servers..


LVL 1
deeburpAsked:
Who is Participating?
 
deeburpAuthor Commented:
solved it..
so apparently something changed on my isp end or something. essentially the default MTU on the network interface for my smtp servers running win 2k3 sp2 was too high so that is why emails would go then stop. because a couple would make it then the connection drops.

i used this link:
http://www.winserverkb.com/Uwe/Forum.aspx/exchange-admin/56496/Long-Outbound-SMTP-Queues-Gmail-AOL-Yahoo

i used this link:
http://support.microsoft.com/kb/900926

once i changed these and rebooted now all email flows properly for gmail. yahoo and other domains without issue.
0
 
spiderwilk007Commented:
I had this same problem a while back and it would only send the emails after I restarted the transport service then they would all send right away, but get stuck and build again in the queue. I believe the problem was resolved when I checked the box labeled "Use the external DNS lookup settings on the transport server" Then everything started flowing again. I have also see similar issues if you don't have a PTR DNS record setup by your ISP.
0
 
spiderwilk007Commented:
Sorry, that check box is on the network tab of your send connector properties.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
deeburpAuthor Commented:
i'm good on mxtoolbox. certainly have ptr and reverse dns functioning properly.
tried putting external dns on my smtp connection as you mention. restarted smtp service.. still have yahoo, gmail and a few other domains stuck.

gmail actually has 7 emails all are queued.. none have been tried yet.
0
 
deeburpAuthor Commented:
also i didn't see a check box. just a place to manually enter external dns per smtp virtual host.
0
 
spiderwilk007Commented:
Sorry, I was telling you the check box for exchange 2007/2010. Are you getting any other errors or logs I can see? What does it say in the queue itself.
0
 
deeburpAuthor Commented:
queue itself says active. "no additional information available". when i find messages each message just shows queued.
0
 
deeburpAuthor Commented:
it's the strangest thing.. so i change the routing connector to one of my other smtp servers to have a lower cost for all outbound emails..

emails move from the problem host to the other smtp host.. and all emails go out. but any new emails are stuck again.
0
 
deeburpAuthor Commented:
initially thought the MTU was the solution but it wasn't

I have a cisco firewall which by default inspects ESMTP traffic

i disabled this scanning to resolve the issue.

when it is default it just stays default inspection or something. I changed the setting via ASDM below should be the output. or via ASDM go to (Firewall>Configuration>Service Policy Rules. edit the Inspection default and disable ESMTP under Rule actions

policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
0
 
deeburpAuthor Commented:
this was the solution after a lot of google searches was able to find someone else having my issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.