need to use php request_uri

using windows server 2008 r2 standard sp1


i tried installing all and dialog box
windows standalone installer
this update is not applicable to your computer


Install this update to resolve an issue in which a PHP application dependent on the REQUEST_URI server variable fails in Internet Information Services (IIS) 7.0. After you install this item, you may have to restart your computer. This update is provided to you and licensed under the Windows Server 2008 License Terms.




 IMPORTANT: Install the Update for the FastCGI Module
The update for the IIS 7 FastCGI module fixes several known compatibility issues with popular PHP applications. Install the update from one of the following locations:

•Update for Windows Server 2008
•Update for Windows Server 2008 x64 Edition
•Update for Windows Server 2008 for Itanium-based Systems
•Update for Windows Vista SP1
•Update for Windows Vista SP1 for x64 based Systems
LVL 1
rgb192Asked:
Who is Participating?
 
Ray PaseurCommented:
Two thoughts... First, consider getting off Windows and use Linux - must easier and many fewer bugs.  Second, consider getting a professionally hosted environment at a hosting company.  I use that kind of thing for all my sites - both test and live - and it saves me literally hours of work every month for just a few dollars!
0
 
Erdinç Güngör ÇorbacıPHP Development Team LeaderCommented:
would you please attach a php_info output with any necessary fields masked.
0
 
rgb192Author Commented:
>>Second, consider getting a professionally hosted environment at a hosting company
I am using a hosting company

but am not using parallels control panel

where php is already built, I have to install it myself
0
 
rgb192Author Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.