• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 521
  • Last Modified:

Cisco Pix ACL's Not working

Hello
So I was messing with a PIX because I needed ping to be enabled on it for monitoring purposes. Not sure what I did but now any AClL/Port forwarding/NAT is not working. My web/FTP servers are down. Anyone see any errors in my config below.
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password o5Xgbfn5Tpqqxmrt encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit tcp any host 209.172.184.90 eq www
access-list outside_access_in permit tcp any host 209.172.184.93 eq www
access-list outside_access_in permit tcp any host 209.172.184.90 eq https
access-list outside_access_in permit tcp any host 209.172.184.90 eq ftp
access-list outside_access_in permit tcp any host 209.172.184.92 eq ftp
access-list outside_access_in permit tcp any host 209.172.184.93 eq ftp
access-list outside_access_in deny tcp any host 209.172.184.90 eq 3389
access-list outside_access_in permit tcp any any eq 1433
access-list outside_access_in permit tcp any host 209.172.184.90 eq ssh
access-list outside_access_in permit tcp any host 209.172.184.92 eq ssh
access-list outside_access_in permit tcp any host 209.172.184.93 eq 3389
access-list outside_access_in permit tcp any host 209.172.184.92 eq www
access-list inside_outbound_nat0_acl permit ip any 172.22.184.128 255.255.255.12
8
access-list inside_outbound_nat0_acl permit ip 172.22.184.0 255.255.255.0 172.22
.185.0 255.255.255.0
access-list outside_cryptomap_20 permit ip 172.22.184.0 255.255.255.0 172.22.185
.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 209.172.184.94 255.255.255.248
ip address inside 172.22.184.89 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNIPPool 172.22.184.151-172.22.184.200
pdm location 172.22.184.90 255.255.255.255 inside
pdm location 172.22.184.91 255.255.255.255 inside
pdm location 172.22.184.92 255.255.255.255 inside
pdm location 172.22.184.93 255.255.255.255 inside
pdm location 172.22.184.128 255.255.255.128 outside
pdm location 172.22.185.0 255.255.255.0 outside
pdm location 209.172.184.93 255.255.255.255 inside
pdm location 75.18.75.72 255.255.255.248 outside
pdm location 72.54.37.40 255.255.255.248 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 0 209.172.184.93 255.255.255.255 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 209.172.184.90 172.22.184.90 netmask 255.255.255.255 0 0

static (inside,outside) 209.172.184.91 172.22.184.91 netmask 255.255.255.255 0 0

static (inside,outside) 209.172.184.92 172.22.184.92 netmask 255.255.255.255 0 0

static (inside,outside) 209.172.184.93 172.22.184.93 netmask 255.255.255.255 0 0

route outside 0.0.0.0 0.0.0.0 209.172.184.89 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 75.18.75.72 255.255.255.248 outside
http 72.54.37.40 255.255.255.248 outside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 209.172.185.180
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 209.172.185.180 netmask 255.255.255.255 no-xauth no-
config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 172.22.184.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local VPNIPPool
vpdn group PPTP-VPDN-GROUP client configuration dns 209.172.128.2 209.172.128.8
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username jronne password *********
vpdn username scperrez password *********
vpdn username jgarza password *********
vpdn username dtburr password *********
vpdn username hgc password *********
vpdn username telesight password *********
vpdn enable outside
dhcpd address 172.22.184.2-172.22.184.80 inside
dhcpd dns 209.172.128.2 209.172.128.8
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:29701c1cfa4ece66a91833163ba4395e
: end
0
moefriedman
Asked:
moefriedman
  • 3
  • 2
1 Solution
 
moefriedmanAuthor Commented:
Oh and my VPN still works.
0
 
SaineolaiCommented:
The access-list is not applied to your outside interface, did you delete and re-enter the access-list?  If so you need to also add this command:

access-group outside_access_in in interface outside
0
 
lrmooreCommented:
Looks like you simply did not re-apply the acl to the interface

access-group outside_access_in in interface out

0
Exciting career futures for women in IT

Education has the power to transform lives and open the door to new career opportunities. By earning an IT degree from WGU, you can become a highly skilled IT professional. Get the credentials and certifications you need to become a leader in this rewarding field.  

 
lrmooreCommented:
Wow! Same time responses... mine just a hair too slow!
0
 
moefriedmanAuthor Commented:
Thanks Gents just figured out 5 minutes after you posted.
0
 
moefriedmanAuthor Commented:
Sorry lrmoore, as I accepted solution, your post came up.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now