Can't add task sequence on usb media

Posted on 2011-05-10
Last Modified: 2013-11-21
Hello All,

This one is driving me crazy..  I can build the os, capture the os, create task sequences, and finally add them to a standalone boot media.   However, I can only do this for CD/DVD ISOs.  I cannot get the USB flash drive to be recognized by SCCM.    I right click the task sequence and select "Create Task Sequence Media".   I choose "stand-alone media".   Finally.. it auto picks CD/DVD.   I manually pick USB but says it can't be null.    The server indeed picks up the drive though.

I tried this on the console that exists on the SMS primary site server.  I tried this on a  sccm console on my own workstation.   I can't get it to light up.   This would make my life so much easier if we can do this :)

SCCM 2007 R2

Any ideas?   Thank you all for any input
Question by:SA-mattman
    LVL 46

    Expert Comment

    There are some more details at the link below, but basically you have to go manual.  SCCM isn't engineered to work with USB, so you have to do all of this via custom code.
    LVL 10

    Assisted Solution

    There is a utility called WinToFlash which can take any bootable CD/DVD and convert/copy it to Flash USB drives so that they are bootable like the CD.
    LVL 8

    Assisted Solution

    The USB stick has to be formatted using Win7 or Win2k8

    I'll post some further details using DISPART tomorrow...  Off work today!!

    Author Comment

    I've seen 3 good options that can be a work around such as..

    1) WinFlash (as Kezzi pointed out)
    2) YUMI  Multiboot USB Creator
    3)  unetbootin

    These all appear to be good alternatives.   However, I can't understand why Microsoft's own USB media creator won't work.   SCCM isn't exactly cheap..  I would hope to utilize tools it has should have for that sake.

    Markie, I tried formatting with ntfs and exfat.   Neither would still show me the drive :(  Thanks

    Accepted Solution

    I figured out what was going on..  both hard drives I tried were considers mass storage devices and not removable storage devices.  I found a smaller sandisk drive that was picked up as a removable storage device.  I plugged it in and it was detected just fine by sccm.

    Thanks all though.

    Author Closing Comment

    Reason above

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    ##the calculator has been updated to version 1.6 please download the use the updated version## Hi there, After the previous post of the original version of the calculator here :…
    Problem Description: Actually I found the below issue with some customers after migration from SMS 2003 to SCCM 2007 and epically if they change site code, some clients may appear in the console with old site code, plus old sites still appearing …
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    9 Experts available now in Live!

    Get 1:1 Help Now