SBS not sending mail

Hello,

I have an aged SBS2003 box which is now, not sending e-mail. Receive yes, send no. SMTP seems to be working as I can telnet to it and get a response. The server has mail sent to, and sent from, directly, no connectors. I can look-up remote server MX records with NSLookup and  I can browse the web without issues. According to MXTools.com, the server is not on any blacklist.

It just stopped working. I am not sure why.

I have; rebooted the server, restarted all of the services, modified the registry to allow for Exchange databases >18GB in size (current db size is 18.1GB), tried a new forwarding DNS server.

Any ideas.
LVL 27
Jason WatkinsIT Project LeaderAsked:
Who is Participating?
 
IntegrityOfficeCommented:
Can you check with your ISP if the will let you use them as a smart host. You could then set them to be a relay.

Also can you just check it is not your firewall by running a command prompt and typing telnet mail.btconnect.com 25 and make sure you at least get a connection. Also if you go to your queue viewer you should see the messages inthe queue and there are some very basic clues in there too. Sometimes ISP request authentication.
0
 
Jason WatkinsIT Project LeaderAuthor Commented:
I do not get any telnet connections to the suggested domain. The firewall administrator does not allow me any kind of administrative access.

Why would using a smarthost be necessary now. It has worked this way for the last three years? The queue shows absolutely nothing of value, only the waiting messages.
0
 
IntegrityOfficeCommented:
Using a smart host sometimes offers better support, using your own server can sometimes cause messages to be held up by remote spam filters from time to time ( in my experience ). As mentioend maybe your ISP has applied a new smtp filter that requires you to use them or require authentication etc. I would check with them.

Also you should be able to telnet port 25 out of your network somehow as a test to make sure that your firewall admin guy has not just closed the port down by accident.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Jason WatkinsIT Project LeaderAuthor Commented:
Attached is a screen-shot of what mxtools reports. I can telnet to the host, suggested above, from another machine just fine.
Screen-shot-2011-05-10-at-8.45.4.png
0
 
Suliman Abu KharroubIT Consultant Commented:
Check with your ISP if they block port 25 on your IP address. it happens.
0
 
Jason WatkinsIT Project LeaderAuthor Commented:
Firewall was it. Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.