exchange 2003/2010 mixed environment NDR issue

Hi All,

I have a mixed environment with 1x Exchange 2003 and 1x Exchange 2010 server.

everything works fine with the exception of NDR (non-deliverable replies).

I have an internal connector betwen the 2 Exchange server with the below mail flow:

User sends email ==> Exchange 2010 ==> Exchange 2003 ( ==> internet

external internet user sends email ==> (mx record: smtp/perimeter server w/ antispam/antivirus software ==> Exchange 2003 ==> exchange 2010 ==> recipients

When I'm checking the queue vis System Manager, I often notice a connection queue for with emails sending from the queue the emails look like it's returning NDRs but it's stuck in the queue because the email addresses are adding the "mail" to the domain, i.e.

So I'm thinking there's a setting somewhere that i need to change so that when postmaster is replying, that the emails will be sent to

Any clue where I might need to change this?
Who is Participating?
jetli87Connect With a Mentor Author Commented:
figured out the issue...Had a misconfig on "masquerade domain" setting...I changed it and now my NDRs are being received fine.
Shabarinath RamadasanInfrastructure ArchitectCommented:
Can you please post the NDR message?
On another note, why don't you change the inbound Internet mail to come into Exchange 2010? You are going to have to do this at some stage when you want to decommission Exchange 2003
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

jetli87Author Commented:
The NDR message is stuck in the exchange 2003 queue.

Emails are pointed to our perimeter smtp server cause it has our anti-virus/spam software on it that filters the emails and forwards to exchange 2003...I'll be decommissioning Exchange 2003 within two weeks, in which point, the emails will be directed to Exchange 2010.
Why don't you just test redirecting it to Exchange 2010 now and see if that gets rid of your NDR issue too?
Well done and thanks for the update.
jetli87Author Commented:
figured it out on my own.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.