[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 545
  • Last Modified:

Alert ! /dev/sda2 does not exists (Debian 4.0)

hi
i need help!!

yesterday i copied linux system by using Knopix .

Server 1 ( Knopix)  ( Source)
dd if=/dev/sda | nc 192.168.0.12 1234

Server 2 (knopix) (Destinatino)
nc -l -p 1234 | dd of=/dev/sda

now i boot the destination,
It starts to boot ..

then it drop me to shell as

=======================
Waitting for root file sytem
check root = bootarg /cat/proc/cmdline

or missing moduels, devices cat /proc/moudules ls /dev/

Alert /dev/sda2 does not exists



i boot this server with live Cd again

and it has

fidsk -l
-bash: fidsk: command not found
aeromarkcvs:~# fdisk -l

Disk /dev/sda: 80 GB, 64424509440 bytes
255 heads, 63 sectors/track, 7832 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            7590        7832     1951897+  82  Linux swap / Solaris
/dev/sda2   *           1        7589    60958611   83  Linux

Partition table entries are not in disk order


What shall i do now ??

Please advise urgent



Bellow is my kernel :

title           Debian GNU/Linux, kernel 2.6.24-etchnhalf.1-686
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.24-etchnhalf.1-686 root=/dev/sda2 ro vga=788 acpi=off
initrd          /boot/initrd.img-2.6.24-etchnhalf.1-686
savedefault

title           Debian GNU/Linux, kernel 2.6.24-etchnhalf.1-686 (single-user mode)
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.24-etchnhalf.1-686 root=/dev/sda2 ro single
initrd          /boot/initrd.img-2.6.24-etchnhalf.1-686
savedefault


0
fosiul01
Asked:
fosiul01
  • 3
  • 2
2 Solutions
 
wesly_chenCommented:
Check this one
http://www.dedoimedo.com/computers/ubuntu-initrd-bug.html
----- Solution
Check files in /boot directory.

Compare each file size with original system. The copy the missing ones or size mismatch one.
0
 
fosiul01Author Commented:
It was "dd" copy as you can see.. so i am 100% sure that every thing was copied properly....

and it was nto any upgrade  ..


but i will try to copy /boot directory from origial one to this server again.. let see if it helps.. but has doubt
0
 
wesly_chenCommented:
Please check the "Analyzing the problem" in that URL,
It might give you the clue for your issue.
Besides, compare before copying anything.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
rindiCommented:
Sometimes you have to change from sda to hda, depending on the disk controller used. Also check your /boot/grub/grub.cfg and /etc/fstab files (the config file in grub might be a different name, depending on the distro and version). Newer distro's don't use /dev/sdx etc but rather labels, and these are unique to the partition, so you may have to edit the files to use the actual label.
0
 
fosiul01Author Commented:
I just took a chance by  chaning kernel input from /dev/sda2 to /dev/hda2

like bellow

 /boot/vmlinuz-2.6.24-etchnhalf.1-686 root=/dev/sda2 ro vga=788 acpi=off

to

 /boot/vmlinuz-2.6.24-etchnhalf.1-686 root=/dev/hda2 ro vga=788 acpi=off


it worked fine

0
 
fosiul01Author Commented:
thanks
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now