[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Message size exceeds fixed maximum message size

Posted on 2011-05-11
13
Medium Priority
?
1,651 Views
Last Modified: 2012-05-11
I have an issue where an end user is trying to send an email into the domain but keeps getting a bounce back saying that message size exceeds fixed maximum message size.

The email is 17mb in size and i increased the allowed message limit via server config > hub transport > receive connectors > default to 19mb but still cannot receive the email.

Do i need to apply the limit anywhere else or is there another way of checking the allowed message size?
0
Comment
Question by:Daniel Bertolone
  • 5
  • 5
  • 2
  • +1
13 Comments
 
LVL 7

Expert Comment

by:d3ath5tar
ID: 35736386
Does the user or the mailstore they are in have a limit set as well?
0
 
LVL 7

Expert Comment

by:Praveen Balan
ID: 35736902
Hope you are facing issue when receiving the email which are more in size(as you said 17 MB email). follow the discussion below, that talks a little about this same situation.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_26846812.html

If you are having issues in sending big emails, you need to look at the sending limit on transport configuration. refer the article mentioned below,

http://www.msexchange.org/articles-tutorials/exchange-server-2007/management-administration/exchange-2007-message-size-limits.html
http://exchangeshare.wordpress.com/2008/04/24/exchange-2007-where-to-set-message-mail-size-limit/

If the NDR is generated from the destination domain, you will have to contact them for the limit that they have set.


-Praveen
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 35737471
The message size limits have to be set in several locations. The following SBS 2008 specific article outlines where and how to do so:
How Do I Change Message Size Limits in Exchange 2007
http://blogs.technet.com/b/sbs/archive/2008/10/28/how-do-i-change-message-size-limits-in-exchange-2007.aspx
If using the POP3 Connector you should also view:
http://blogs.technet.com/b/sbs/archive/2009/07/01/sbs-2008-introducing-the-pop3-connector.aspx

Keep in mind not all servers on note to you may support messages of that size. 6GB seems to be the standard that works consistently though many sites are expanding to 10GB and much more. This is especially importnat when using the SBS POP connector and a hosting company.
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 

Author Comment

by:Daniel Bertolone
ID: 35737710
Thanks rob.

I changed the settings as per one of the link's above and my limits are as follows:

Max send Size: 10MB
Max receive Size: 2000KB

Any reason why its showing kb instead of mb?
0
 

Author Comment

by:Daniel Bertolone
ID: 35738120
Even though I changed the limits i am still unable to receive the email. External user keeps getting the same bounce back.

Do I need to restart any of exchanges services for the limits to come into effect?
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 35738228
Are you using the POP3 connector? As I recall you were in another post. If so it may be out of your hands. The host may not accept messages of that size.
0
 

Author Comment

by:Daniel Bertolone
ID: 35738267
Hi rob

No this is a different site that gets its mail delivered straight to exchange
0
 
LVL 78

Assisted Solution

by:Rob Williams
Rob Williams earned 1000 total points
ID: 35738646
Technically you should only have to set the receive connector size with a command such as:
Set-ReceiveConnector “Windows SBS Internet Receive Servername” –MaxMessageSize 20MB

However if the global receive size is set less than this it will override. You can check that under:
Organization Configuration | Hub Transport | Global Settings tab | Transport Settings | properties | General

Also if per user/per mailbox limits have been set they too will override. You can verify they are set to unlimited with:
Get-mailbox | ft Name, MaxSendSize, MaxReceiveSize

Though the article doesn't state it is necessary, generally Exchange configuration changes require a reboot or at least re-starting Exchange services.

Where are you seeing the "200 KB" limit? PowerShell?
0
 

Author Comment

by:Daniel Bertolone
ID: 35752870
Hi Rob

The global receive size is set to 20480 KB

Also all of the user’s mailbox limits are set to unlimited but i still cannot receive the email.

I was thinking the issue could lay on the sender’s server but the bounce back points to us.
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 35753235
Try sending a large attachment from a 3rd party site to confirm.

Keep in mind trying to work with attachments of this size is not practical because of common limits by most servers.
0
 

Author Comment

by:Daniel Bertolone
ID: 35753443
Just sent a 17mb email from 3rd party site & get exactly the same message that the recipient server rejected the message due to file size.

The limit must still be enforced somewhere
0
 
LVL 7

Accepted Solution

by:
Praveen Balan earned 1000 total points
ID: 35753453
Hi,

Since you use the SBS;I would recommend to recycle the services/restart the server, it should work ideally.  

Verify every point and ensure you did not miss to do any configuration changes. The link below dsicussed the same issue and the requester confirmed the issue is resolved.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_26846812.html

As I have previously mentioned, below article explains every possible area where the limit can be restricted. Verify every such points and recycle the services/restart server.
http://exchangeshare.wordpress.com/2008/04/24/exchange-2007-where-to-set-message-mail-size-limit/

I Hope this will resolve your issue, follow every steps.

-Praveen
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 35757669
Agreed. Did you reboot the server after the changes? Restarting the Exchange services should do the trick, but if not see if a reboot will cause it to "kick in".
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to effectively resolve the number one email related issue received by helpdesks.
Stellar Exchange Toolkit: this 5 in 1 toolkit comes loaded with mega-software tool. Here’s an introduction to tools’ usage and advantages:
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses
Course of the Month18 days, 2 hours left to enroll

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question