[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2804
  • Last Modified:

Access Denied on https://host/vd/replisapi.dll?diag

My environnement is a Windows Server 2008 64 bits server with SQL Server 2005.
I'm trying to configure IIS for web replication on this server.

I have followed the instruction on http://msdn.microsoft.com/en-us/library/ff714039.aspx
Now when I try to access to the web page https://host/vd/isapi.dll?diag and authenticate with the administrator login, everything is fine.
But when I try with the replication account i've created for this purpose then I get an "access denied" on the navigator. I've got this error even if the replication account is in the administors group.

I'm looking for what access right is missing for hours.

Thank's for your help.
0
Yuan38
Asked:
Yuan38
  • 8
  • 7
1 Solution
 
lcohanDatabase AnalystCommented:
Did you set permissions for the SQL Server Replication Listener for that account?

0
 
Yuan38Author Commented:
The replication account is 'sysadmin' on SQL Server security settings.
I don't know where to configure the SQL Server Replication Listener permissions. Can you tell me where to do this ...
0
 
lcohanDatabase AnalystCommented:
So you created a SQL login called "sysadmin" as the replication account you mentioned below?
....
<<But when I try with the replication account i've created for this purpose then I get an "access denied" on the navigator>>
.....
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
lcohanDatabase AnalystCommented:
Just perform the tasks from the link below in order to "Setting Permissions for the SQL Server Replication Listener"

http://msdn.microsoft.com/en-us/library/ms152511.aspx
0
 
Yuan38Author Commented:
I'm not using a sysadmin account. I just mean that the account used for replication has the 'sysadmin' role in SQL Server.

I've followed the instructions in the link mentionned. One of the task ask to add the created account for replication in the IIS_WPG group : but this group is not present in the list (I'm using Windows Server 2008 x64). I've added the replication account to the IIS_IUSRS group.
0
 
Yuan38Author Commented:
I'm still having "Access Denied" when trying to access to the web page https://host/vd/isapi.dll?diag when I authenticate with the account used for replication.
0
 
lcohanDatabase AnalystCommented:
OK so let's recap,,,you listed your question for SQL 2005 but you run SQL 2008 x64 bit right?
Is the NT login you created a Domain or Local login on the computer where you tried to run the web page? it should be a NT Domain account not just local login.
Did you tried it from another computer on the same domain?
0
 
lcohanDatabase AnalystCommented:
My bad...you run SQL 2005 on Windows x64...sorry. Is it SQL 2005 64bit as well?
0
 
Yuan38Author Commented:
Yes It's SQL Server 2005 x64 on Windows Server 2008 x64.
The server is not in a domain => all the accounts used are 'local'
0
 
lcohanDatabase AnalystCommented:
<<I'm trying to configure IIS for web replication on this server.>>

The how did you performed 7 - c from link below?

 http://msdn.microsoft.com/en-us/library/ms152511(v=SQL.90).aspx

You were supposed to enter the domain in there right?

"To configure the computer that is running IIS by using the Configure Web Synchronization Wizard"
c.In the Default Domain and Realm boxes, enter the domain of the computer that is running IIS.

0
 
Yuan38Author Commented:
I'm using IIS 7 so the parameters for IIS are a bit different from IIS6. On IIS7 there is no place for any domain name in the authentication parameters (see the screen capture).

iis7-auth.jpg
0
 
Yuan38Author Commented:
If I un the "Configure Web Synchronization ..." wizard, on the "Authenticated Access Page", I simply left he Default domain and Realm boxes empty.
0
 
lcohanDatabase AnalystCommented:
Hmm.....so with all installed and configured on that same computer you can hit and run the  https://host/vd/isapi.dll?diag IF you log on that box as local user "administrator" right? But not with another local user even if it is in the local "administrators" group. There must be some right speciffic issue as a local "administrator" is not the same as THE administrator in windows 2008.


They say that "To run Web synchronization in diagnostic mode, you must be an administrator on the computer running IIS." but did you tried with that user to run just the isapi.dll?
Someting like https://host/vd/isapi.dll
 
0
 
Yuan38Author Commented:
After running once again the "Configure Web Synchronization ..." wizard and check again all the parameters it now works !!
May be because now, I just have the "Basic Authentication" enabled and all the other set to "disabled".


0
 
lcohanDatabase AnalystCommented:
That's what it was recommended in the article right? I thought about that when you posted the authentication and saw you have both basic and windows enabled plus that the computer is not on a domain...well I'm glad its finaly working for you!
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now