Can't disable Telnet on Cisco router for SSH

I have read every site on how to disable telnet on a cisco router and enable SSH but one part is not working for me. Telnet still works.

I started with generating the key and then stating SSH version 2:

username MY_NAME privilege 15 password PASSWORD
IP Domain-name mydomain.com
crypto key generate rsa
(with modulus 1024)
IP SSH version 2

line vty 0 4
transport input ssh
login local

...and yet TELNET still works, SSH works too now but I need Telnet not to work.
Maximus54Asked:
Who is Participating?
 
greg wardSystems EngineerCommented:
line vty 5 15
 no login

~Does that mean they cant login or they dont have to login?
if its the second then then they can freely access lines 5 to 15.

once a user has opened a telnet connection can you use the command show line and paste the output.

Greg
0
 
greg wardSystems EngineerCommented:
can you do a show line and paste the output so we can see which line is connected.

Also

line vty 5 15
transport input ssh
login local


Greg
0
 
lhcsdDirector of TechnologyCommented:
I believe the line config command you're looking for is:

no transport input telnet
0
 
Maximus54Author Commented:
lhcsd: the No transport input is invalid

Here is my config Greg:

line vty 0 4
 exec-timeout 30 0
 logging synchronous
 login local
 history size 50
 transport input ssh
line vty 5 15
 no login
!
scheduler allocate 20000 1000
!
end
0
 
Maximus54Author Commented:
deepdraw:
You got it, I was trying to disable vty Lines 5 to 15 and only allow 4 virtual terminal connections but I guess that No Login command made it so that they were still able to telnet instead of SSH to those lines. All I did was take out the No Login command and add the Transport input ssh for VTY 5 15 and now Telnet is disabled. Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.