Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 305
  • Last Modified:

Cand delete a record from a front end database in Access 2003

Access 2003 on XP SP3. Front end on several desktops and back end data on a workgroup computer.  One person cannot delete any record from a continuous form on the front end on her computer. I have recopied the front end. No access level rights installed.  Others can delete form records. She cant. I'm stumped.
0
Mixmangle
Asked:
Mixmangle
  • 6
  • 5
1 Solution
 
Nick67Commented:
Likely she doesn't have write rights to the folder/file where the backend is stored.
Check the NTFS permissions on the backend
0
 
als315Commented:
Can she add new and edit records? Is it always same person?
If no & yes:
Check rights for shared folder with Back end (try to copy file to this folder and delete it).
What XP version is installed? Home or Professional?
How many users are working in your DB?

0
 
MixmangleAuthor Commented:
Her rights are no different than anyone else. She can go into the same folder as the backend, save a document. Open and edit and delete document.  Normally there's nothing else in this folder but I had her do this just to see.  I said in my original post XP SP 3 and she also has SP3 of Office 2003.  I have deleted the front end several times and reinstalled it.  There are maybe 6-8 people in the backend at a time but they have their own FE.  And the particular area she is deleting is not something that is locked by someone else in that record. It's an area within the Backend that very few access.  
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
Nick67Commented:
Ok,

Does the problem follow the users or the machine?
Have her logon somewhere else and see if the problem follows her.
Have someone else logon the problem workstation.

Then post up how it went
0
 
MixmangleAuthor Commented:
Good idea!  Hadn't tried that yet.  Will do
0
 
Nick67Commented:
< I have deleted the front end several times and reinstalled it.>

Does this mean torn out and re-installed Access, or deleted and copied the front-end?

Here's another simple troubleshooting step that costs little time.
Shut the workstation down.
Unplug it
Count to 40
Plug it in
Restart it.

You'd be surprised how often the 'magic reboot' fixes problems that shouldn't exist, but do.
0
 
MixmangleAuthor Commented:
Thanks Nick but reboot does not solve problem.  And I was thinking that the file creation/edit/deletion would have verified rights so I thought I would try to have her log on somewhere else. She does, and she can delete just fine. It has nothing to do with her rights.   But If someone else logs onto her computer the delete function is not available to them either!!!!

So, the issue is not with her account or her rights but with her computer.

I have not uninstalled Access and reinstalled it. I have simply deleted the access FE several times.  I guess the only thing open to me is to delete/reinstall access???  Not a big deal, but I was so user the problem was elsewhere. I guess not?
0
 
Nick67Commented:
No, don't tear out Office just yet.
That does take a whack of time, and may not solve it.

So, the problem is the one computer, with every user.
Every user?
Local Administrator?
Domain Admin?
Can anyone logged on to that unit do things properly?

Is the backend an Access file (must be, but I'd better ask)?
If you copy the back-end to a different folder, and relink tables to just the problem machine's front end,will it work?

Another simple step to attempt.
Reboot the backend computer.  Maybe it has some funky brain-fart going on.

Let me know
(is the problem Access or just where the back-end is located is what this is meant to naarow down)
0
 
MixmangleAuthor Commented:
The problem seems to be on that computer with every user. A give user full admin rights, or log on as locfal administrator, makes no difference.

This is on a Novell network, and the backend is actually a Novell server.  User has correct rights. It's a default template that every other user has.  I went in and verified individual memberships. They also have 8-10 different front End databases that connect to the same backend and this issue comes up nowhere else.

In addition, I have had this user log onto a computer somewhere else on the network and access the same fe and she can delete files fine

The one AHA! thing that I have not done yet is put a copy of backend on local computer and repoint the links to the local copy. That will be interesting to try.  I know EE thinks this question is abandoned. But in the real world, we cant get back to the same issue so fast.  Your patience is appreciated.  I will try moving the BE to local computer and get back . . . but it will not be for a week or so. I will be on leave, and will pick back up when I get back.  Thanksw!
0
 
Nick67Commented:
<and the backend is actually a Novell server.>

That is a bit of a different kettle of fish altogether!
Many fun things to go wrong.
Netware 5,6,7 or SUSE Linux?
Client32?

The original post was for <on a workgroup computer.>
Netware is monstrously picky about times on the server and workstation being in sync.

Definitely make a copy of the backend and try a different folder on the server, and putting the backend local and relinking
0
 
MixmangleAuthor Commented:
I still got the same thing when I linked the backed locally.  So I ended up completely uninstalling Access 2003 and reinstalling it, leaving the other components in place. When I did, everything worked fine from that point on.  Still cant explain it. No other variables to my knowledge were changed.

Points go to you for sticking with me and helping me think it through.
0
 
Nick67Commented:
Thanks man!
Glad you got it working
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now