Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 770
  • Last Modified:

column in wrong position in internet explorer

Hello,
I am using Joomla 1.6 and the component Phoca Gallery.

The phoca gallery worked fine in all browsers except some pcs running IE8 and lower.  I have four columns set up in the categories view. I had to increase the width of the container and the phoca gallery because the fourth column would wrap around below the rest of the gallery. Now I have the fourth column to the right of the third column as it should be, but it is slightly lower than the rest of the columns. I have included an image.

http://www.black-cardinal.net/joomla1/log/zia.JPG

This is a link to the actual site which may or may not appear correctly depending on the browser used to view it.

http://renaissancebuttons.com/zia/index.php/wholesale-catalog

I have used the Internet Explorer Developer on the pc that had the problem to try and troubleshoot the issue, but I have the same configurations for all of the columns.  

It looks like extra padding or margin is being added to the top of the fourth column, but I have no idea how to get rid of it.

Any help would be greatly appreciated.
0
tiabradford1984
Asked:
tiabradford1984
  • 3
  • 3
  • 3
1 Solution
 
AmickCommented:
Set the column width for the 4 columns to less than 25%, 24.75% worked for me, in order to allow for the issue.
0
 
SSupremeCommented:
Replace:
<form name="adminForm" action="http://renaissancebuttons.com/zia/index.php/wholesale-catalog" method="post" style="width:700px;">
0
 
tiabradford1984Author Commented:
Thanks for the replies

Amick and SSupreme where can I find the file to make these changes? Using firebug, it appears to be an inline style and not in the phocagallery.css file.?

Tia
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
AmickCommented:
Go to Components - Phoca Download - Control Panel - click on icon Options (Parameters) (you can find this icon in top right corner of your Joomla! administration). There you can find an option for number of columns and column width percentage. If you change the option to not-equal, I think you are able to specify column widths for each column at design time rather than having them calculated.

0
 
SSupremeCommented:
That line you can find in your markup HTML or PHP or ASP.
0
 
tiabradford1984Author Commented:

Amick

If I use the Equal Percentage Column Width and change to No then the fourth column jumps back down below the other columns on the next line. This seems to happen in all browsers now.

Tia
 button
0
 
SSupremeCommented:
Add this to any css file you have:
form {width:100%;}
0
 
AmickCommented:
Tia,

OK, that was a bad idea.  I thought you'd have an opportunity to provide guidance as to column width but apparently I didn't remember the interface correctly.
0
 
tiabradford1984Author Commented:
No problem,

Thanks Amick.  I tried the option above for

form {width:100%;}

and it cleared up the bug right away. I really appreciate your help.

Thanks SSupreme! Been trying to figure this out for a few weeks now.  I can finally get some sleep :)
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now