?
Solved

site to site VPN using two cisco asa 5505

Posted on 2011-05-11
6
Medium Priority
?
470 Views
Last Modified: 2012-05-11
I cannot get this site to site to work.  I have these two firewalls as vanilla as I can get.  I have used the ASDM and CLI both to no avail.I have them both connected via ethernet cable on e0/0.

Someone throw me a bone here please....

Config fw MDV
ASA Version 8.2(1)
!
hostname MDV
enable password z3Vhv168HZLEetUh encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 128.0.0.0 mdv
name 10.201.10.0 cpf
name 192.168.2.0 mdv-cpf-int
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 128.1.70.100 255.255.0.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
object-group network DM_INLINE_NETWORK_1
 network-object mdv 255.0.0.0
 network-object mdv-cpf-int 255.255.255.0
object-group network DM_INLINE_NETWORK_2
 network-object cpf 255.255.254.0
 network-object mdv-cpf-int 255.255.255.0
access-list outside_1_cryptomap extended permit ip mdv 255.0.0.0 object-group DM_INLINE_NETWORK_2
access-list inside_nat0_outbound extended permit ip 128.1.0.0 255.255.0.0 object-group DM_INLINE_NETWORK_1
access-list inside_nat0_outbound extended permit ip mdv 255.0.0.0 object-group DM_INLINE_NETWORK_2
access-list site_to_site extended permit ip mdv 255.0.0.0 192.168.1.0 255.255.255.0
access-list noNAT extended permit ip mdv 255.0.0.0 cpf 255.255.254.0
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list noNAT
nat (inside) 1 0.0.0.0 0.0.0.0
route outside cpf 255.255.254.0 192.168.2.1 1
route outside 0.0.0.0 0.0.0.0 192.168.2.1 tunneled
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 128.1.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group5
crypto map outside_map 1 set peer 192.168.1.1
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 5
 lifetime 86400
telnet 128.1.0.0 255.255.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 128.1.70.104-128.1.71.103 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group 192.168.1.1 type ipsec-l2l
tunnel-group 192.168.1.1 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
 

Config fw CPF

ASA Version 8.2(1)
!
hostname CPF
enable password z3Vhv168HZLEetUh encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 128.0.0.0 mdv
name 192.168.2.0 mdv-vpn-int
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.201.10.2 255.255.254.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
object-group network DM_INLINE_NETWORK_1
 network-object mdv 255.0.0.0
 network-object mdv-vpn-int 255.255.255.0
access-list outside_1_cryptomap extended permit ip 10.201.10.0 255.255.254.0 object-group DM_INLINE_NETWORK_1
access-list inside_nat0_outbound extended permit ip 10.201.10.0 255.255.254.0 object-group DM_INLINE_NETWORK_1
access-list site_to_site extended permit ip 10.201.10.0 255.255.254.0 mdv-vpn-int 255.255.255.0
access-list noNAT extended permit ip 10.201.10.0 255.255.254.0 mdv 255.0.0.0
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list noNAT
nat (inside) 1 0.0.0.0 0.0.0.0
route inside 10.201.10.0 255.255.254.0 10.201.10.2 1
route inside 10.201.10.1 255.255.255.255 10.201.10.2 1
route outside mdv 255.0.0.0 192.168.1.1 1
route outside mdv-vpn-int 255.255.255.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.201.10.0 255.255.254.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group5
crypto map outside_map 1 set peer 192.168.2.1
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 5
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.201.10.6-10.201.10.133 inside
dhcpd enable inside
!
             
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group 192.168.2.1 type ipsec-l2l
tunnel-group 192.168.2.1 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:35a17b225d1a1f24d3b6a8541a038c37
0
Comment
Question by:redcell5
6 Comments
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 35741512
I never can get them to work with perfect forward secrecy.

no crypto map outside_map 1 set pfs group5

Shareef
0
 
LVL 8

Accepted Solution

by:
Saineolai earned 2000 total points
ID: 35741568
The access-list which identifies the networks marked for encryption need to be mirror images of each other at each side.  They are not in your case:

access-list outside_1_cryptomap extended permit ip 128.0.0.0 255.0.0.0 object-group DM_INLINE_NETWORK_2

access-list outside_1_cryptomap extended permit ip 10.201.10.0 255.255.254.0 object-group DM_INLINE_NETWORK_1

You need to redefine these access-lists.
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 35742054
can u post results from following commands:
show crypto isakmp sa
show crypto ipsec sa
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
LVL 2

Expert Comment

by:erdelgad
ID: 35742841
Hello,

I found this link that may be usefull for you.

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a0080950890.shtml

Please check your configuration and reply back if you have any question.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 35745069
First thing I noticed:
Both firewalls have an outside address of: 192.168.1.1 255.255.255.0

You might want to change that.........
0
 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 35748146
Yeah Ernie I noticed that to. I'm guessing it is a typo otherwise he would more problems then just his VPN :)
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When speed and performance are vital to revenue, companies must have complete confidence in their cloud environment.
Will you be ready when the clock on GDPR compliance runs out? Is GDPR even something you need to worry about? Find out more about the upcoming regulation changes and download our comprehensive GDPR checklist today !
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question