Getting Macs to Self-Register in DNS

All of my windows hosts on the network seem to self-register in DNS when they grab an address
through DHCP.  But the few folks in the office with Mac of Linux systems do not become known
in DNS.  Is there something in those systems that can be switched on to permit self-registration
in DNS?
LVL 1
amigan_99Network EngineerAsked:
Who is Participating?
 
Duncan RoeConnect With a Mentor Software DeveloperCommented:
Seriously, I have suggested at work that DHCP and DNS services should be offloaded from the Windows server onto a Linux server, to fix exactly the problem you have, at last for the Linux systems. It seems from another Q that it may not work for Macs.
I'll keep looking for the message I mentioned in http:#35750666
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
This does not work with Windows DNS unless you allow anonymous dns updates. You will need to disable authentication on your dns servers and then the machines may register.
0
 
gheistCommented:
you can enable DNS updates from DHCP server.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
Duncan RoeSoftware DeveloperCommented:
I have often seem this problem with Windows DHCP and Linux clients. DHCP does not forward the name supplied to DNS - Windows clients expect this behaviour and update DNS with their names later, but Linux (and now, it seems, also Macs) do not.
Everything works if you serve DNS / DHCP from a Linux system, as I do at home. I see error messages in the DNS log from Windows clients subsequently trying to do name updates (which are unnecessary because DNS got the name from DHCP).
I have tried to identify what these packets look like, so I can have Linux clients at work send them to the Windows DNS there, but so far without success. That's what the Macs need to do
0
 
amigan_99Network EngineerAuthor Commented:
So I went into DHCP - and Enable Dynamic DNS was checked with option "Dynamically update DNS A and PTR records only if requested by DHCP clients the DHCP client".  I could see my mac user in the DHCP leases "mtruckermac" at 10.10.10.99.  But if I did nslookup for 10.10.10.99 it showed some past Windows PC that used to have the address - mooshilt.  

I changed the check box to "Always dynamically update DNS A and PTR records".  Then I deleted the lease for mrtruckermac and told the mac dude to grab a new address.  He did this by configuring a static IP address and then setting back to DHCP dynamic assignment.  It pulled the same old address as it had before and DHCP again showed mrtruckermac with 10.10.10.99 in lease.  But old mooshilt still had the DNS entry.

Could it be the case that DHCP service has to be restarted?  How can one view the dynamically assigned DNS entries?  If I go into DNS configuration I do not even see entry mooshilt 10.10.10.99.  Secure and nonsecure DNS updates have been permitted all along.  So that is not the issue.
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
THIS DOES NOT WORK.  You have to change the security of your DNS server to allow anonymous updates.
0
 
amigan_99Network EngineerAuthor Commented:
Nappy - where do you do  that exactly?  As you can see in the attached grab - I only see permission to all nonsecure or secure dynamic updates.  I don't see anything regarding "Anonymous".
ScreenHunter-07-May.-16-15.52.gif
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Yes by selecting Nonsecure and secure, the Nonsecure are anonymous updates.
0
 
amigan_99Network EngineerAuthor Commented:
So I changed a few things in DHCP and DNS but still neither the Macs nor iPads are winding up in DNS. :-(  The names do appear in the DHCP lease table.  e.g. JoeBobsiPad has IP address 10.10.10.72.  But this association is not winding up in DNS.  In properties for the reverse zone for 10.10.10.0 Dynamic Updates is set to "Nonsecure and secure".  And in DHCP properties for the zone - if I go to the DNS tab - "Enable DNS dynamic updates according.." is checked and then "Always dynamically update DNS A and PTR records" is also checked.  But as I say - this is not succeeding in getting the Macs and iPads into DNS.  

There is an empty option at the bottom "Dynamically update DNS A and PTR records for DHCP clients that do not request updates".  But that sounds almost identical to "Always dynamically update DNS A and PTR records".  What is the difference?  What else might I need to do to ID these Macs and iPads etc?
0
 
Duncan RoeSoftware DeveloperCommented:
The forward (normal) lookups  are A records, the reverse lookups are PTR records. You need to update both of them therefore. I would turn on that empty option.
0
 
amigan_99Network EngineerAuthor Commented:
It was no go adding the empty option.  Any other tips on getting these pups to register in DNS?
0
 
Duncan RoeSoftware DeveloperCommented:
I don't use a GUI interface to configure my DHCP / DNS. The below configs work for me with Windows hosts. I posted them to another Q but haven't heard back if they worked for the asker:
06:45:17$ cat /etc/dhcpd.conf 
option domain-name "mshome.net";
option domain-name-servers 127.0.0.1;
ddns-update-style interim;
ignore client-updates;

subnet 192.168.0.0 netmask 255.255.255.0
{
  range 192.168.0.5   192.168.0.119;
  range 192.168.0.121 192.168.0.254;
  max-lease-time 2592000;
  default-lease-time 604800;
  option subnet-mask 255.255.255.0;
  option broadcast-address 192.168.0.255;
  option routers 192.168.0.120;
  option domain-name-servers 192.168.0.120;
}
06:49:17$

Open in new window

Host 192.168.0.120 is the router / DNS / DHCP.
06:45:17$ cat /etc/dhcpd.conf 
option domain-name "mshome.net";
option domain-name-servers 127.0.0.1;
ddns-update-style interim;
ignore client-updates;

subnet 192.168.0.0 netmask 255.255.255.0
{
  range 192.168.0.5   192.168.0.119;
  range 192.168.0.121 192.168.0.254;
  max-lease-time 2592000;
  default-lease-time 604800;
  option subnet-mask 255.255.255.0;
  option broadcast-address 192.168.0.255;
  option routers 192.168.0.120;
  option domain-name-servers 192.168.0.120;
}
06:49:17$ cat /etc/named.conf 
acl "locals" { 10.255.255.0/24; 192.168.0.0/24; 127.0.0.0/8; };
options {
  directory "/var/named";
  forward only;
  forwarders { 198.142.0.51; 203.2.75.132; };
  allow-transfer { none; };
  allow-query { "locals"; };
  allow-recursion { "locals"; };
};

zone "mshome.net" IN {
  type master;
  file "mshome.net";
  forwarders { };
  allow-query { "locals"; };
  allow-transfer { "locals"; };
  allow-update { 192.168.0.120; };
};
zone "0.168.192.in-addr.arpa" IN {
  type master;
  file "ten.emohsm";
  forwarders { };
  allow-query { "locals"; };
  allow-transfer { "locals"; };
  allow-update { 192.168.0.120; };
};
zone "local.net" IN {
  type master;
  file "local.net";
  forwarders { };
  allow-query { "locals"; };
};
zone "255.255.10.in-addr.arpa" IN {
  type master;
  file "ten.lacol";
  forwarders { };
  allow-query { "locals"; };
};
06:52:16$

Open in new window

0
 
amigan_99Network EngineerAuthor Commented:
Duncan - our DNS server is Windows based.  How can I apply this?  Thanks.
0
 
amigan_99Network EngineerAuthor Commented:
Thanks Duncan.  At least that helps to know it appears to be a known issue with Windoze DNS/DHCP.  Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.