• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 805
  • Last Modified:

Certificate Issue

We have a server. On that server I setup RDP Gateway Services and all that stuff. That server IP is 192.168.50.x.

There is a sonicwall firewall , 168.100.175.x. I added a rule that forwards to 192.168.50.x if it is port 443.

I am using a self signed certificate that the RDP gateway service created, and used the FQN of wsremote02.remote.com

I took that certificate and installed it on my client machine here, Local machine Trusted Root whatevers.

I try to run the RDP and get this:

 "This computer can't verify the identity of the RD Gateway "server name" It is not safe to connect to servers that can't be identified..."
Clicked view certificate: This CA Root certificate is not trusted. To enable trust, install this certificate in the trusted root certification authorites store.

I went to certmgr.msc and it shows it under that store and it does not say its "not trusted".  Any ideas?

Local machine OS - Win7
0
fleets9876
Asked:
fleets9876
1 Solution
 
spiderwilk007Commented:
All self-signed certs by defualt are not trusted, so unless you are on the same lan you will get the certificate error. You can purchase a public cert from digicert, godaddy, verisign etc. Then it will be trusted by all clients.
0
 
Leon FesterCommented:
Agreed, if you've publishing certificates for public sites then get an certificate which a verifiable ROOT.
Have a look at http://www.startssl.com/ for a free certificate.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now