Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1080
  • Last Modified:

ASP .NET 2.0 on IIS 7.5 - Event ID error 3010 when launching site

Hi Everyone,

I'm getting the below errors in the below Application Log when launching my site on IIS 7.5  It previously worked fine on IIS 6.0.  Any ideas how I can fix this?

Thanks in advance,
Theo

Event code: 3008
Event message: A configuration error has occurred.
Event time: 5/11/2011 3:19:40 PM
Event time (UTC): 5/11/2011 10:19:40 PM
Event ID: bac01447f1e446a4a8b3df2b6855cb72
Event sequence: 1
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/24/ROOT-5-129496259800783046
    Trust level: Full
    Application Virtual Path: /
    Application Path: D:\Inetpub\vhosts\intranetpages.com\httpdocs\
    Machine name: PURCHASINGDESK-W01
 
Process information:
    Process ID: 4648
    Process name: w3wp.exe
    Account name: PURCHASINGDESK\IWPD_22(rockyourhea)
 
Exception information:
    Exception type: ConfigurationErrorsException
    Exception message: Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
 
Request information:
    Request URL: http://purchasing.intranetpages.com/ 
    Request path: /
    User host address: 169.231.189.15
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: PURCHASINGDESK\IWPD_22(icinardi)
 
Thread information:
    Thread ID: 5
    Thread account name: PURCHASINGDESK\IWPD_22(icinardi)
    Is impersonating: False
    Stack trace:    at System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase)
   at System.Web.Configuration.Common.ModulesEntry..ctor(String name, String typeName, String propertyName, ConfigurationElement configElement)
   at System.Web.HttpApplication.BuildIntegratedModuleCollection(List`1 moduleList)
   at System.Web.HttpApplication.GetModuleCollection(IntPtr appContext)
   at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
   at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
   at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
   at System.Web.HttpApplicationFactory.GetPipelineApplicationInstance(IntPtr appContext, HttpContext context)
   at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
 
 
Custom event details:
0
Theodosios
Asked:
Theodosios
1 Solution
 
Sammy AgeilCommented:
check the framework your app pool is set to use.
by default IIS 7 looks uses framework 4.0 once its installed.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now