[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 500
  • Last Modified:

Exchange OWA wont work

Hi

I am trying to get OWA working but to no avail. I have gone through some of the steps on this web page

http://www.msexchange.org/tutorials/SSL_Enabling_OWA_2003.html

I install the certificate and then try to run http://server/certsrv to get the pending certificate request accepted in IE but it comes up with page not found.

Thanks in advance.

Scott
0
cbapartnership
Asked:
cbapartnership
  • 13
  • 12
2 Solutions
 
Sanjay SantokiCommented:
Hi Scott,

I would be in good position to assist you, if you can share the screen shot of the error.

Thanks,
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
Hi Sanjay

This is my error message.

 IE Error
0
 
Sanjay SantokiCommented:
Hi,

OWA URL should be https://servername/owa or https://servername/exchange

You will get actual error If you disable friendly error message from browser.

IE -> Tools -> Internet Options -> Advance -> untick "show friendly HTTP error message"

Thanks,
Sanjay Santoki
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
cbapartnershipAuthor Commented:
I havent got as far as testing the owa yet. I am trying to get the certificate setup first. Its when attempting to get the "Pending Request" accepted by the CA that I get the error. According to the web link in my first post,it says to go to http://server/certsrv.
0
 
Sanjay SantokiCommented:
Hello,

Have you installed Certificate authority on the server?

Can you please provide a screen shot from the following steps.

Open IIS manager -> Properties of default web site -> Directory Security -> Server Certificate -> Next
Open IIS manager -> Properties of default web site -> Directory Security -> View Certificate

Thanks
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
1
The second screen shot you asked for - view ceritificate is greyed out
0
 
Sanjay SantokiCommented:
Hi,

If you have submitted CSR to local CA server,  you have to approve certificate request from certificate authority through below steps.

Open Certificate Authority from administrative tools -> Pending Request -> Right click and approve. Once you approve request, CA will generate certificate in issue certificate. Go to Issued Certificate -> Double click on the certificate for which you have requested -> Details -> Copy to File -> Next -> Save file - > Next -> Finish

Open IIS manager -> Properties of default web site -> Directory Security -> Server Certificate -> Next -> Next -> select the file from which you have saved in above step -> Next -> Finish

Thanks,
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
There are no pending requests in CA. I have tried doing a new certificate but it still doesnt show up in CA.
0
 
Sanjay SantokiCommented:
Hello,

Are you submiting CSR after generating it from the website? If not first of all you have to generate CSR (Certificate Request) from website and need to submit it to CA. Once it is submitted to CA, you have to follow steps provided in previous post.

Thanks,
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
Sorry, you've lost me a bit. I havent been to any web site to generate it. How do I generate one from a web site please?
0
 
Sanjay SantokiCommented:
Hello,

Please refer below article how to generate CSR.

http://www.digicert.com/csr-creation-microsoft-iis-5-6.htm

Thanks,
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
Thanks for the link.

I have got as far as step 11 but I don't know where to copy and paste the text too.
0
 
Sanjay SantokiCommented:
Hello,

Where you able to save CSR file as certreq.txt. If so open Certificate authority -> Right click on the servername -> All Tasks -> Submit new request -> submit the file generated.

Once you submit CSR a request generate under pending requests -> right click and approve.

Go to Issued Certificate -> Double click on the certificate for which you have requested -> Details -> Copy to File -> Next -> Save file - > Next -> Finish

Open IIS manager -> Properties of default web site -> Directory Security -> Server Certificate -> Next -> Next -> select the file from which you have saved in above step -> Next -> Finish

Thanks,
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
When I click on submit new request and select the certreq.txt file, I get the following error

 2
0
 
Sanjay SantokiCommented:
Hello,

Perfom the following steps:
1). Start->Administrative Tools->Certificate Authority
2). Expand the intended certificate authority node on the left pane.
3). Select "Certificate Templates", Check if the following templates available:

* Domain Controller Authentication -------- For Windows 2003
* Domain Controller ----------------------- For Windows 2000
If they are not there, perform step 4)
4). Highlight "Certificate Tempates" on the left pane, and right click it, select
"new", then click "certificate to issue".
5). An "Enable Certificate Templates" dialog popup, Press "Ctrl" key and select the following
Certificate Templates, then click "OK".
* Domain Controller Authentication
* Domain Controller
6). Restart the certificate Authority by select it on the left pane, then click the black
square on the tool bar to stop it, then click the black triangle to start it.
7). Congratulations, you have enabled the certificate template needed to issue Domain

Thanks,
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
In my Certificate templates, there is a "Domain Controller" template but not a "Domain Controller Authentication" template. My server runs SBS 2003 so I am assuming that there should be a "Domain Controller Authentication" template. I have tried to add it as in step 5, but there isn't an option for the template.

Many thanks for your help so far though. It is very much appreciated.
0
 
cbapartnershipAuthor Commented:
Good morning Sanjay

I seem to have got a bit further but then got stuck again. I have now managed to get onto the http://server/certsrv site to request a certificate. I get to the stage where I copy and paste the text from the certreq.txt file and then click submit. I then get the following error.

 2
0
 
Sanjay SantokiCommented:
Hello,

I would like you to reinstall Certificate authority or install operating system service pack if missing.

Thanks
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
Hi

Sorry for the late reply. I have been trying all sorts.and dont seem to be any further on. I have reinstalled the certificate autority as well as the create a new certificate and that seems to have gone fine. But when I try to test it with https and http://server/exchange I get "Internet explorer cannot display the webpage".

Thanks
0
 
Sanjay SantokiCommented:
Hi,

Have you installed (published) new certificate on your default web site ?

Thanks,
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
Yes
0
 
Sanjay SantokiCommented:
Hello,

You can try https://127.0.0.1/exchange or http://127.0.0.1/exchange

Also, be sure required IP address binded with the website and website is not stopped. Also, please restart IIS service once.

Thanks,
Sanjay Santoki
0
 
cbapartnershipAuthor Commented:
I have tried both the links but the same problem.

What exactly do you mean by "be sure required IP address binded with the website"?

The web site is running (I take it you mean the default web site)? And I have also restarted the IIS service.

Thanks
0
 
cbapartnershipAuthor Commented:
If I go into default web site > properties > directory security > secure communications > edit and then take out the tick boxes for the SSL bit, I can then use the http://server/exchange. So does that mean there is something wrong with my certificate?
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

  • 13
  • 12
Tackle projects and never again get stuck behind a technical roadblock.
Join Now