Problems booting preinstalled OMAP3 Natty (11.04) Image on the BeagleBoard rev C4

Posted on 2011-05-12
Last Modified: 2012-05-11

I'm trying to install Ubuntu Natty on the beagle board rev c4. These are the steps followed :

0.Got the Ubuntu Natty image from :
1.Inserted the SD card in my host computer's SD card reader.
2.Identified the correct device name.
3.Ran the following command to write it:

sudo sh -c 'zcat ubuntu-11.04-preinstalled-headless-armel+<omap image>.img.gz > /dev/<device name>'

4.Ran Putty on the host computer (running on Ubuntu 10.10 x86) using these parameters :

a) Set the serial port to /dev/ttyS0.
b) Set the communications settings to 115200 8N1.
c) Turned Hardware Flow Control off.
d) Set the Software Flow Control off.
e) Turned on the Beagle Board and followed the instructions explained at the bottom of this page :

On omap3 systems with a modified NAND (i.e. beaglebord C series) done the following:

On a serial console connected to the system, halted the autoboot script and typed :
setenv bootcmd 'mmc init;fatload mmc 0 0x82000000 boot.scr;source 0x82000000'; setenv autostart yes; saveenv; boot

The screenshot attached explains what happened.
Question by:marietto2008
    LVL 38

    Expert Comment

    ---- Quote ---
    as soon as I run 'mmc part 0' I can magically boot.
    LVL 2

    Author Comment

    yes,it worked,but as soon as ubuntu makes the boot,the busybox console appears on the screen. Is this right ? what's the next step to do,then ?
    LVL 38

    Expert Comment

    Check the beagleborad beginner guide
    LVL 2

    Author Comment

    What should I check on the beagleboard beginner guide,precisely ?
    LVL 38

    Accepted Solution

    Sorry I wish I could help but I don't have beagleboard.
    I guest you can start from (4 First interaction with the board)
    Check everything and then develop your own stuff.
    LVL 2

    Author Closing Comment

    He helped me partially.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    Suggested Solutions

    The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
    In this post we will learn how to connect and configure Android Device (Smartphone etc.) with Android Studio. After that we will run a simple Hello World Program.
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now