• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2262
  • Last Modified:

SCCM client will not install remotely on Windows 7 clients



I have been using a script to remotely deploy software including the SCCM client. On the Windows XP machines this has worked without fail.

I ensure that the pre-requeistites are installed e.g. WindowsUpdateAgent30-x86, WindowsInstaller etc. and then the run the ccmsetup on the client.

On some Windows 7 systems the same process is not working (see attached log). When I noticed that the client was not installing, I logged in and ran CCMSetup manually.

At first it looked like it had hung, so I terminated the install. I launched it again and then did a BITSAdmin / list /allusers. BITsAdmin showed that data was being transferred from Windows Update. Once it completed, CCMSetup installed the agent without any further issues.

I have a load of other machines with the same issue. BITsadmin shows


BITSADMIN version 3.0 [ 7.5.7600 ]
BITS administration utility.
(C) Copyright 2000-2006 Microsoft Corp.

BITSAdmin is deprecated and is not guaranteed to be available in future versions
 of Windows.
Administrative tools for the BITS service are now provided by BITS PowerShell cm
dlets.

{FB910488-83F9-475E-9B23-1CB1C699215C} 'CcmSetup BITS Version Check' SUSPENDED 0
 / 0 0 / 0
{F375EC88-A07C-48F6-B39E-9073111A6DC3} 'CCMSETUP DOWNLOAD' SUSPENDED 0 / 0 0 / 0

{EDCE7A7D-FD6D-4393-B9A3-DE747F80CD3C} '{AC76BA86-7AD7-1031-7B44-A93000000001}'
QUEUED 0 / 1 0 / UNKNOWN
Listed 3 job(s).

Can anyone offer any suggestions?
ccmsetup.log
0
aideb
Asked:
aideb
  • 5
  • 3
3 Solutions
 
merowingerCommented:
Download the MP Troubleshooter which is part of the ConfigMgr 2007 Toolkit and check you Management Point and Distribution Points Configuration.
Also check the Site Status for Errors.
Which Setup Parameters have you defined and how did you build your environment? Server Locator Points?, DNS, WINS, AD Extension?!
0
 
aidebAuthor Commented:
Hi,

The setup parameters are

CCMSetup.exe /mp:EU-ESG-SCCM-01 /logon SMSSITECODE=ESG

Our directory has been extended. We only use DNS.

The MP Troubleshooter gives a clean bill of health. XP clients are fine, only Window 7

Thanks
0
 
merowingerCommented:
Can you please post a clean ccmsetup.log where no manual installation is logged. It's difficult to differ the installations
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
aidebAuthor Commented:
Here is a clean one...Only a remote installation attempted


ccmsetup.log
0
 
rockatansky74Commented:
Is the firewall running on the Windows 7 clients?
0
 
aidebAuthor Commented:
To mitigate that I have run

netsh advfirewall set allprofiles state off

Which should prevent that interfering....same issue however

0
 
merowingerCommented:
0
 
aidebAuthor Commented:
Got it.....I was using PSExec in the scripts and it will not install the client properly if -S switch is not used (System)

Here's what worked for me

psexec -s \\%Computername% \\eu-esg-sccm-01\sccmclient\CCMSetup.exe /mp:EU-ESG-SCCM-01 /logon SMSSITECODE=ESG

Allocating you the points for all your help!

Cheers
0
 
aidebAuthor Commented:
Thanks!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now