Name resolution

Within 2003 Active Directory Integrated DC DNS is configured to scavange old RR's. DHCP configured to lease addreses.

Now recently I am able to ping the host by IP address but not by host name.
Performing name resolution with NSLOOKUP both forward and reverse fail with an error
***servername.fqdn can't find 10.x.x.x: non-existent domain

Checking in DNS under the address range these RR's have been deleted by scavenging
Checking in DHCP the IP Addresses are still leased to to hosts.
(More that one host affected)

When I perform a NBTSTAT -a IP of aaffected host it gives me the name table of the host.

Where am I going wrong/ what am I overlooking?
Hosts affected are all Winterm hosts.

Thanks in advance.



chobberAsked:
Who is Participating?
 
chobberConnect With a Mentor Author Commented:
Issue resolved

Secure dynamic DNS update has been configured and a domain controller is running on the same host as the DHCP server, but credentials for DNS update have not been configured


Configure DNS dynamic update credentials

To configure DNS dynamic update credentials

Open DHCP.

In the console tree, click the applicable DHCP server.

Where?

DHCP/applicable DHCP server

On the Action menu, click Properties.

In Server Properties, click the Advanced tab, and then click Credentials.

The DNS dynamic update credentials dialog box appears.

In DNS dynamic update credentials, type the information required to provide credentials that will determine DNS record ownership, and then click OK.
0
 
ActiveDirectorymanCommented:


I do not understand what you are saying.  are you trying to resolve the records that were scavenged?

are the records that you are trying to resolve in dns ?

try this:

nslookup

set type=a

type the name of the host record you are looking for.
0
 
chobberConnect With a Mentor Author Commented:
Thanks for the response.

Sorry for not being clearer. Yes those records have been scavenged. And to some degree I know thats the reason why I cannot perform a forward /reverse lookup to those hosts as the RR's are no longer there.

What puzzles me is that I can ping the IP address and this is ok. Though I am unable to ping by host. Yes I know this wont work if the RR's have been scavenged. But looking within DHCP the IP addresses is still leased to the hosts.

I tried your sugestion NSLOOKUP->set type=a
though I received the same result
***Servername.FQDN can't find 10.x.x.x: non-existant domain
0
 
chobberAuthor Commented:
Pints rewarded to myself for the hard work
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.