Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1118
  • Last Modified:

Can't RDP to server 2003

I have a Windows 2003 server that I want to RDP to, but I can’t connect to it.  The server is not a domain controller and doesn’t have Active directory installed.  I have ticked the ‘Enable remote desktop on this computer’ tickbox in System > Remote tab and have specified users.  I don’t think the Terminal services service is running as I don’t see port 3389 listed when I use Netstat.
0
grsg
Asked:
grsg
  • 18
  • 8
  • 4
  • +7
1 Solution
 
rpartingtonCommented:
whats the error message when you try to remote to it
0
 
Ernie BeekExpertCommented:
But did you check the service?
0
 
grsgAuthor Commented:
Error messages reads - Remote desktop can't connect to the remote computer for one of these reasons etc..., do you need the entire message?  The Terminal services service is listed as started in Services, should I do something more?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Spike99On-Site IT TechnicianCommented:
The entire message would be helpful.

Do you get the error after typing in the user credentials, or before you see the logon prompt for Windows?

Are the client PCs attempting to connect to a terminal server on the same network or is it at a remote location?  Can they log on to the server using the IP address?

Just an FYI: on Terminal Servers, it's better to give remote users access to the server by adding them to the local "Remote Desktop Users" group rather than using the Remote Access feature under system properties.
0
 
Joshua_MCommented:
Is Windows Firewall enabled? If that is on you won't be able to reach it.
0
 
grsgAuthor Commented:
Windows Firewall is enabled, but there is an exclusion for Remote Desktop.  I get the following error message when I try to RDP to the server 'The client could not connect to the remote computer. Remote connections might not be enabled or the computer might be too busy to accept new connections. It is also possible that network problems are preventing your connection. Please try your connection again later. If the problem continues to occur, contact your administrator. ' The message appears before getting the chance to enter credentials.  There is no other machine on the network other than the laptop I want to use to RDP to it.  Using the IP address makes no difference, still can't connect.  The is not setup as a Terminal server, it's a file server and I just want to RDP to it to administer it.  I think that covers all questions.

0
 
fdvfd dfrfvCommented:
access your server physical
Go to manage on your computer icon.
Go to Local users and groups
Then you choose groups
Search for Remote Desktop User en add Administrator account.
Try it again
0
 
grsgAuthor Commented:
Thanks Alte17, have already tried this, the admin accounts are listed but still it won't work.  I feel like the service isn't listening, but I don't know enough to confirm this.  Netstat shows that port 3389 isn't listening, does this help anyone.
0
 
fdvfd dfrfvCommented:
Try to disable your firewall on that server for a moment, the try again.
0
 
grsgAuthor Commented:
disabled Firewall, exactly the same message.
0
 
fdvfd dfrfvCommented:
did you recently  apply windows update  ?
We have had these problems too, a second reboot was needed to get actief again.
0
 
grsgAuthor Commented:
I've had this problem for the past four weeks since the server was built.
0
 
Tek_ServicesCommented:
You need a static Ip address assigned to the server and the router will need to to be set up for application port pass thru. In a Linksys router it's under Application and gaming. port range fowarding.
use port 3389 to 3389  and the static ip address you assigned to the server.
0
 
johnb6767Commented:
Reset the firewall, in case of a corrupted exception.....

start>run>cmd

netsh firewall reset

Then disable it again, and retest....
0
 
johnb6767Commented:
And uncheck the remote box, and go back in and recheck it once again....
0
 
fdvfd dfrfvCommented:
Try to restart your server
0
 
grsgAuthor Commented:
The server does have a static IP address.  I'm on the local LAN trying to RDP to the server, so I don't need to worry about port forwarding yet.  I reset the firewall and followed johnb6767's instructions, but I still get the same error.  I've just done a netstat -a and 3389 is not listed, this makes me think the Terminal service service is not listening, can anyone suggest how to test this further.
0
 
Ernie BeekExpertCommented:
Go to: administrative tools->terminal services configuration, click connections and see if a connection is there. If not, right click connections and create a new one.

See if that helps.
0
 
rpartingtonCommented:
I would as a test turn the servers firewall off completely and then try remoting to it via IP address not netbios.
Also can you ping the server from the same client PC that you are trying to RDP from using netbios and via IP.

0
 
grsgAuthor Commented:
A connection exists in Terminal services configuration.  The Firewall is disabled and I still can't connect via IP or hostname.  The server reponds to ping from my client PC.  I also notice I can't even RDP to the server's from itself, i.e., it's loopback address, it just doesn't seem to be listening.
0
 
Ernie BeekExpertCommented:
Do you have the server listening to ms-wbt-server?
That should be port 3389.

So, any antivirus running that might be interfering?
0
 
grsgAuthor Commented:
No antivirus running.  I don't know what ms-wbt-server is, so I haven't setup the server to listen for it.  Hope I've understood you correctly erniebeek.
0
 
grsgAuthor Commented:
Just done netstat and no ms-wbt-server service running.  
0
 
Ernie BeekExpertCommented:
Almost. If you do a netstat -a, is the server listening on port ms-wbt-server ?

So something like:
 Proto  Local Address          Foreign Address        State
  TCP    vsw006:ms-wbt-server   vsw006.wdm.local:0     LISTENING
0
 
Ernie BeekExpertCommented:
Ah, you allready did that (too fast for me :)
0
 
grsgAuthor Commented:
Come on guys, it's like that 80's Bonnie Tyler song, it's getting late and I'm going to need a hero tonight.  Are there any heros out there?
0
 
Ernie BeekExpertCommented:
Well I hope it's not becoming like the stranglers (no more heroes anymore).

Try the following:

 - Download and install devcon.exe from Microsoft. Its a command line device manager tool (http://support.microsoft.com/kb/311272/en-us)
 - Run devcon.exe which will extract it.
 - Open a cmd prompt
 - Navigate to the i386 folder devcon made.
 - Type
      devcon.exe -r install %windir%\inf\machine.inf root\rdpdr
      Wait until it completes.
0
 
grsgAuthor Commented:
I'll do as you suggest, but can you tell me what it's going to do, or how it will help?
0
 
grsgAuthor Commented:
Ran the cmd, you didn't tell me it would shutdown my server like that, oh well, what next?  (I'm a believer, Monkeys)
0
 
grsgAuthor Commented:
By the way, still can't connect using RDP
0
 
Ernie BeekExpertCommented:
It will try to (re)install the Terminal Services Client Device Redirector (http://dll.paretologic.com/detail.php/rdpdr)
In lots of cases like yours this helps to get the server listening again.
0
 
Ernie BeekExpertCommented:
Ehr, I'm sorry (Brenda Lee) that was the -r switch.

Anything showing in netstat though?
0
 
grsgAuthor Commented:
Still no port 3389 listed using netstat
0
 
MazdajaiCommented:
Can you provide an output for the following command?

C:\WINNT\system32\drivers>dir term*

C:\WINNT\system32>dir term*

Open in new window

0
 
grsgAuthor Commented:
Hi Mazdajai, out as requested below:

C:\WINDOWS\system32\drivers>dir term*
 Volume in drive C has no label.
 Volume Serial Number is 840A-C117

 Directory of C:\WINDOWS\system32\drivers

17/02/2007  15:18            41,608 termdd.sys
               1 File(s)         41,608 bytes
               0 Dir(s)  225,508,605,952 bytes free

C:\WINDOWS\system32\drivers>

C:\WINDOWS\system32>dir term*
 Volume in drive C has no label.
 Volume Serial Number is 840A-C117

 Directory of C:\WINDOWS\system32

22/03/2006  13:00               862 termcap
17/02/2007  15:03           359,936 termmgr.dll
17/02/2007  15:03           245,760 termsrv.dll
               3 File(s)        606,558 bytes
               0 Dir(s)  225,508,524,032 bytes free

C:\WINDOWS\system32>
0
 
MazdajaiCommented:
Any error messages (TermDD or related) in the event viewer?
What version of mstsc? (Right mouse on Upper left of the remote desktop window, About)
Based on your term files, I assume this is a 32bit box, is it R2?
Did you remote remote desktop from the troubled server?
Does remote desktop ever work? Or it never work at all?

I would agree that unless u see port 3389 on the listening, we can assume remote desktop is broken. This is not connection issue.
0
 
MazdajaiCommented:
correction* = Did you try remote desktop from the troubled server to another server
0
 
grsgAuthor Commented:
No error mesasges related to  Terminal services in event viewer. RDP client is ver 6.0.6001.  The server is server 2003 SP 2, not R2.  Remote desktop has never worked, the box is approx one month old.  Re your RDP from troubled server question, not quite sure what you're asking, but I can't rdp from the server to it's loopback address and I can't rdp to the server from a LAN client.  Port 3389 is not listening, so I think the problem must be connected to that.  Keep it coming.
0
 
MazdajaiCommented:
Did you have this hotfix installed with the latest patches? (Should have asked in the first place)

KB925876

If you do for both questions and rdp still broken, I would recommend you to do a clean install.
0
 
grsgAuthor Commented:
That patch/update was installed in March and all subsequent upates are installed.

Like I said earlier, I really need a hero tonight, is there a hero out there that can help?
0
 
bcapelloCommented:
Have you checked to see which port RDP is using?  It can be changed.  To check which port follow these instructions:

1.  Run Regedt32 and go to this key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
NOTE: The above registry key is one path; it has been wrapped for readability.

2.  Find the "PortNumber" subkey and notice the value of 00000D3D, hex for (3389). Modify the port number in Hex and save the new value.
0
 
grsgAuthor Commented:
bcapello nailed it.  The port number had been changed and the individual had not thought to tell me, thanks to evryone who offered advice.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 18
  • 8
  • 4
  • +7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now